New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #23591 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

MacFuse cannot activate

Reported by: oshea@… Owned by: dports@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: MacFuse

Description (last modified by jmr@…) (diff)

macbook-pro-17:~ owner$ sudo port -d install macfuse 
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/fuse/macfuse
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/fuse/macfuse
DEBUG: OS Platform: darwin
DEBUG: OS Version: 10.2.0
DEBUG: Mac OS X Version: 10.6
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port macfuse.
DEBUG: Requested variant i386 is not provided by port macfuse.
DEBUG: Requested variant macosx is not provided by port macfuse.
--->  Computing dependencies for macfuse
--->  Activating macfuse @2.0.3_0
DEBUG: Image error: /Library/Application Support/Developer/Shared/Xcode/Project Templates/MacFUSE already exists and does not belong to a registered port.  Unable to activate port macfuse.
    while executing
"_activate_contents $name $imagefiles $imagedir"
    (procedure "portimage::activate" line 56)
    invoked from within
"registry_activate $name ${version}_${revision}${portvariants} [array get user_options]"
    (procedure "eval_targets" line 21)
    invoked from within
"eval_targets activate"
    invoked from within
"$workername eval eval_targets $target"
    (procedure "mportexec" line 85)
    invoked from within
"mportexec $workername $target"
Error: Unable to execute port: Image error: /Library/Application Support/Developer/Shared/Xcode/Project Templates/MacFUSE already exists and does not belong to a registered port.  Unable to activate port macfuse.
To report a bug, see <http://guide.macports.org/#project.tickets>
macbook-pro-17:~ owner$ 

Change History

comment:1 Changed 4 years ago by jmr@…

  • Owner changed from macports-tickets@… to dports@…
  • Keywords activate removed
  • Description modified (diff)

Please remember to preview and use WikiFormatting, and to cc the maintainer.

The problem is clearly spelled out in the error message. To activate the port, you would have to move the conflicting file(s).

comment:2 Changed 4 years ago by dports@…

Did you have a non-MacPorts installation of MacFuse before?

comment:3 Changed 4 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.