New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #23671 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

shared-mime-info: XML::Parser perl module is required for intltool

Reported by: clint.olsen@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: ryandesign@…, JensErikWeber@…
Port: shared-mime-info

Description (last modified by macsforever2000@…) (diff)

checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_shared-mime-info/work/shared-mime-info-0.71" && ./configure --prefix=/opt/local --disable-update-mimedb " returned error 1
DEBUG: Backtrace: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_shared-mime-info/work/shared-mime-info-0.71" && ./configure --prefix=/opt/local --disable-update-mimedb " returned error 1
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for shared-mime-info): org.macports.destroot org.macports.configure org.macports.build
DEBUG: couldn't read file "/opt/local/share/macports/Tcl/darwintrace1.0/pkgIndex.tcl": no such file or directory
    while executing
"source [file join $dir pkgIndex.tcl]"
Error: Unable to upgrade port: 1

I have the XML parser installed, so I'm not sure how to satisfy the port system to make this work.

Change History

comment:1 Changed 4 years ago by macsforever2000@…

  • Description modified (diff)
  • Port set to shared-mime-info

comment:2 Changed 4 years ago by ryandesign@…

  • Cc ryandesign@… added
  • Summary changed from Perl version error trying to upgrade shared-mime-info to shared-mime-info: XML::Parser perl module is required for intltool

Clean shared-mime-info and try installing again (sudo port clean shared-mime-info; sudo port install shared-mime-info)

If the same error occurs, try rebuilding p5-xml-parser (sudo port clean p5-xml-parser; sudo port -n upgrade --force p5-xml-parser) and then try installing shared-mime-info again (sudo port clean shared-mime-info; sudo port install shared-mime-info)

comment:3 Changed 4 years ago by ryandesign@…

And if that doesn't work, the problem may be that you appear to be using perl5.10; try using perl5.8 instead (sudo port deactivate perl5.10; sudo port install perl5.8)

comment:4 Changed 4 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #23296.

comment:5 Changed 4 years ago by ryandesign@…

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Well, maybe not. #23296 is for intltool and this ticket is for shared-mime-info. But it's the same error message.

You don't happen to have changed build_arch in macports.conf, have you? What happens when you run

perl -e "require XML::Parser"

(that's the check the configure script runs that's failing, so by running that you should see what the error is)

comment:6 Changed 4 years ago by ryandesign@…

Please see whether r71457 has fixed this.

comment:7 Changed 3 years ago by JensErikWeber@…

  • Cc JensErikWeber@… added

Cc Me!

comment:8 Changed 3 years ago by JensErikWeber@…

This problem appeared now on my Mac, though I had updated my MacPorts installation several times in the meantime since the bug was reported. After forcing upgrade of p5-xml-parser like mentioned in #23296, the upgrade of shared-mime-info worked.

But still, this is a bug that should be repaired, as normal users will give up earlier than us power users or developers.

comment:9 Changed 3 years ago by jmr@…

  • Status changed from reopened to closed
  • Resolution set to worksforme

Without the config.log we'll never know for sure what happened, but in the past this has always been either not doing Migration when needed, or changing perl versions without rebuilding the modules. The latter is a consequence of the way perl module ports work and not a problem with this or any other specific port.

Note: See TracTickets for help on using tickets.