Opened 12 years ago

Closed 12 years ago

#23678 closed defect (duplicate)

kdelibs4 4.4.0 - build fails

Reported by: doug@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: sharky@…
Port: kdelibs4

Description

I can't seem to get this thing to build. Seems like a lot of stuff is in flux.

I'm running 10.5.8 (Intel) with Xcode 3.1.3.

The error I'm getting now...

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/kdelibs-4.4.0/kimgio/jp2.cpp:38: error: expected initializer before '*' token

Attachments (2)

kdelibs4_4.4.0build.log.zip (10.2 KB) - added by doug@… 12 years ago.
kdelibs4-Portfile.diff (368 bytes) - added by rmsfisher@… 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by doug@…

Attachment: kdelibs4_4.4.0build.log.zip added

comment:1 Changed 12 years ago by rmsfisher@…

Keywords: haspatch added

It is missing one dependency: attica. See attached patch.

Changed 12 years ago by rmsfisher@…

Attachment: kdelibs4-Portfile.diff added

comment:2 Changed 12 years ago by doug@…

Actually, I have all the dependencies listed, including attica...

attica @0.1.2_0 (active)

I've even tried cleaning, uninstalling and reinstalling all of the dependencies.

comment:3 Changed 12 years ago by mf2k (Frank Schima)

Cc: sharky@… added
Owner: changed from macports-tickets@… to snc@…
Port: kdelibs4 added

comment:4 Changed 12 years ago by nerdling (Jeremy Lavergne)

Keywords: haspatch removed

comment:5 Changed 12 years ago by djackan@…

I might be wrong here but take a look at this if you: cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/kdelibs-4.4.0/kimgio/ pico jp2.cpp

and look at line 38 you see this:

//unfortunately this is declared as static in JasPer libraries
static jas_stream_t *jas_stream_create()
{
        jas_stream_t *stream;

        if (!(stream = (jas_stream_t*)jas_malloc(sizeof(jas_stream_t)))) {

I don't understand code at all really but where you see the first two asterisks shouldn't it actually be:

static jas_stream_t* jas_stream_create()
{
       jas_stream_t* stream;

Now Like I said I don't understand any of this very well but given that it's in the working directory isn't that temporary and these corrections have to be made somewhere else? Anyway that might give you a lead on the cpp:38 error looks like the asterisk was just accidentally moved forward one space. Hope this is of some use to someone that actually knows what they are doing.

comment:6 Changed 12 years ago by nerdling (Jeremy Lavergne)

Line 38 is okay.

27:27: error: jasper/jasper.h: No such file or directory is what's causing the errors.

comment:7 Changed 12 years ago by djackan@…

I have two instances of jasper.h on my system they are in the following directories:

/Library/Frameworks/UnixImageIO.framework/Headers/jasper/jasper.h

and

/opt/local/include/jasper/jasper.h

I just did the following:

cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/kdelibs-4.4.0/kimgio/

sudo pico jp2.cpp

I went to line 27

and where it says #include <jasper/jasper.h>

I replaced it with #include </Library/Framerworks/UnixImageIO.framework/Headers/jasper/jasper.h>

I don't know if this makes sense, but for some reason kdelibs4 is building without error now on my system. This was the only change I made since the last time I received the error. I hope this is of some help.

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #23427.

Note: See TracTickets for help on using tickets.