Opened 11 years ago

Closed 9 years ago

Last modified 6 years ago

#23684 closed defect (fixed)

libtool @2.2.6b installs sometimes lack dylibs

Reported by: gnw3 Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: drkp (Dan Ports), nilstec_inc@…, gabrielesvelto (Gabriele Svelto), vortexfive@…, ted@…, rob.patro@…, christophe@…, watsodw, michael.secules@…, amruta.ahuja@…, zouhu0628@…, gsiisg@…, jelkink@…, f.calboli@…, kai.vanes@…, cooljeanius (Eric Gallager)
Port: libtool

Description

Have 6 OSX 10.5.8 machines with essentially the same macports 1.8.2 configuration and packages. On some machines we have:

/opt/local/lib/libltdl.7.dylib

others only the static libraries. Our programs compiled on the machines with the .dylib won't run on the others.

For the machines without the dylib, libtool was installed in Nov. (so probably an older version of macports). The ones with the .dylib were installed in Jan. I did:

port uninstall -f libtool; port install libtool

on two of the machines that did not have .dylib but only one of them ended up with the .dylib! The problem appears to be that some users have symbolic links for /opt/local/bin/gfortran. If such links are present, you don't get the dylib.

I have attached the output from "port -d install libtool" from runs with (nodylib.log) and without (libtool.log) the gfortran symlinks

Note that the system that fails to install the .dylib hasL

nodylib.log:libtool.m4: error: problem compiling FC test program

Attachments (2)

libtool.log (89.3 KB) - added by gnw3 11 years ago.
port -d install libtool that installs .dylib
nodylib.log (84.5 KB) - added by gnw3 11 years ago.
port -d install libtool that does not install .dylib

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by gnw3

Attachment: libtool.log added

port -d install libtool that installs .dylib

Changed 11 years ago by gnw3

Attachment: nodylib.log added

port -d install libtool that does not install .dylib

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Keywords: libtool dylib removed
Owner: changed from macports-tickets@… to boeyms@…
Port: libtool added

comment:2 Changed 10 years ago by drkp (Dan Ports)

Cc: dports@… added

Is this what's causing t1lib to sometimes fail to build dylibs (see #25417, #26908)?

Do we have any idea what's causing libtool to do this?

comment:3 Changed 10 years ago by jmroot (Joshua Root)

It doesn't look like this is about libtool failing to build dylibs for other software, but rather about libltdl.dylib being omitted when building libtool itself.

comment:4 Changed 10 years ago by drkp (Dan Ports)

I fail at reading comprehension -- I totally missed that libltdl is part of libtool itself rather than some other random dylib.

Still wonder if it could be related, though, since the problem there appears to be that libtool is not building static libraries, and reinstalling libtool fixed it for at least one person.

comment:5 Changed 10 years ago by drkp (Dan Ports)

Oh, also, per comment:ticket:25417:11, that also appears to be related to having gfortran installed.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

I can't reproduce this problem with libtool 2.4.

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: nilstec_inc@… gabriele.svelto@… vortexfive@… ted@… rob.patro@… christophe@… david.w.watson@… michael.secules@… amruta.ahuja@… zouhu0628@… gsiisg@… jelkink@… f.calboli@… kai.vanes@… added
Resolution: fixed
Status: closedreopened

Has many duplicates including #25417, #26908, #30018, #30037, #30043, #30105, #30106, #30395, #30556, and many posts on the mailing lists. I hereby consolidate all these issues into this ticket, which as far as I can tell is the earliest one.

comment:8 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from boeyms@… to ryandesign@…
Status: reopenednew

I brought the issue up with the developers of libtool on their mailing list, and Peter O'Gorman's reply was that this is a bug in libtool's build. libtool's build looks for a fortran compiler, and when it finds one, but it is broken, it takes note of the fact that the fortran compiler cannot build shared libraries, but this mistakenly overrides the earlier detection that the C and C++ compilers are able to (and should) create shared libraries. Peter provided a solution to prevent libtool from attempting to locate a fortran compiler, which in MacPorts we never want libtool to be doing anyway.

comment:9 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

comment:10 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.