Opened 11 years ago

Closed 10 years ago

#23701 closed defect (fixed)

libdevil build failure

Reported by: acowley@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: raphael-st (Raphael Straub), rubengarciahernandez@…
Port: libdevil

Description (last modified by mf2k (Frank Schima))

libdevil fails to build on Mac OS X 10.4.11

$ sudo port install -d libdevil   
--->  Computing dependencies for libdevil
--->  Building libdevil
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libdevil/work/devil-1.7.8" && /usr/bin/make -j1 all " returned error 2
Command output: Making all in lib
/bin/sh ../libtool --tag=CC   --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I../include/IL  -I ./../src-IL/include -I ./../include -I/opt/local/include -faltivec -maltivec  -O2 -arch ppc -MT libIL_la-il_alloc.lo -MD -MP -MF .deps/libIL_la-il_alloc.Tpo -c -o libIL_la-il_alloc.lo `test -f './../src-IL/src/il_alloc.c' || echo './'`./../src-IL/src/il_alloc.c
libtool: compile:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I../include/IL -I ./../src-IL/include -I ./../include -I/opt/local/include -faltivec -maltivec -O2 -arch ppc -MT libIL_la-il_alloc.lo -MD -MP -MF .deps/libIL_la-il_alloc.Tpo -c ./../src-IL/src/il_alloc.c  -fno-common -DPIC -o .libs/libIL_la-il_alloc.o
./../src-IL/src/il_alloc.c:74: error: conflicting types for 'ivec_align_buffer'
./../include/IL/devil_internal_exports.h:101: error: previous declaration of 'ivec_align_buffer' was here
make[1]: *** [libIL_la-il_alloc.lo] Error 1
make: *** [all-recursive] Error 1

Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.

Change History (5)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to simon@…

comment:2 in reply to:  description Changed 11 years ago by rubengarciahernandez@…

Problem exists on 10.5 Leopard as well

comment:3 Changed 11 years ago by rubengarciahernandez@…

Cc: rubengarciahernandez@… added

Cc Me!

comment:4 Changed 10 years ago by simon@…

Owner: changed from simon@… to macports-tickets@…

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Cc: raphael@… added
Resolution: fixed
Status: newclosed

This was fixed in r75814.

Note: See TracTickets for help on using tickets.