Opened 11 years ago

Closed 11 months ago

Last modified 6 months ago

#23754 closed defect (fixed)

pump mode in distcc

Reported by: kyle.tarplee@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: cooljeanius (Eric Gallager), ryandesign (Ryan Schmidt)
Port: distcc

Description (last modified by mf2k (Frank Schima))

I get this error when running pump

pump scons -j4
__________Using distcc-pump from /opt/local/bin
Traceback (most recent call last):
  File "/opt/local/lib/python2.5/site-packages/include_server/include_server.py", line 42, in <module>
    import distcc_pump_c_extensions
ImportError: dlopen(/opt/local/lib/python2.5/site-packages/include_server/distcc_pump_c_extensions.so, 2): no suitable image found.  Did find:
	/opt/local/lib/python2.5/site-packages/include_server/distcc_pump_c_extensions.so: mach-o, but wrong architecture
__________Expected a socket at '/tmp/distcc-pump.RLL311/socket'
__________Could not start distcc-pump include server
__________Warning: distcc-pump include server failed; running unpumped
__________Found        0 available distcc servers

I don't have python 2.5 installed via mac ports (only 2.6)

Attachments (1)

pythonvariant.patch (999 bytes) - added by arsptr@… 10 years ago.
Patch for portfile

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)

Changed 10 years ago by arsptr@…

Attachment: pythonvariant.patch added

Patch for portfile

comment:2 Changed 10 years ago by arsptr@…

The problem is caused by the fact that the OS python2.5 (which is what distcc detects by default) is 32-bit only, and hence not compatible with 64-bit shared libraries.

The enclosed patch adds python26 & python27 variants, which tell distcc to use the MacPorts python installs. These are built 64-bit and so work perfectly with the 64-bit shared libs.

An alternative solution might be to use the OS X python2.6 install, which is built as a 64- and 32-bit binary, I'll leave that as an exercise for the reader.

comment:3 Changed 9 years ago by kvirkvia@…

This bug is still existent in 2.0.4 version of macports with most up-to-date ports base, afaik, this port now is just a prebuilt binary, with that specified library built for 32bit platform, while I'm running 64 bit one.

comment:4 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 11 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

In 70ceb866139c83268083a9e2a40e7286aae6f5b1/macports-ports (master):

distcc: 3.3.3 and add python variants

Closes: #23754

comment:6 Changed 11 months ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

comment:7 Changed 6 months ago by ryandesign (Ryan Schmidt)

In 70ceb866139c83268083a9e2a40e7286aae6f5b1/macports-ports (dar, master, py38-reproject, revert-6945-rust-1.43.0, wireshark):

distcc: 3.3.3 and add python variants

Closes: #23754

Note: See TracTickets for help on using tickets.