Opened 16 years ago

Closed 15 years ago

#2384 closed defect (fixed)

BUG: sbcl-0.8.16

Reported by: bugs@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: waqar@…
Port:

Description

sbcl-0.8.16

port file wont install, building fails with the following error.

(SB-IMPL::REQUIRE-ERROR 3 "Don't know how to ~S ~A.")[:EXTERNAL]

0] error Don't know how to REQUIRE ASDF. See also:

The SBCL Manual, Variable *MODULE-PROVIDER-FUNCTIONS* The SBCL Manual, Function REQUIRE

restarts (invokable by number or by possibly-abbreviated name):

0: [CONTINUE] Continue anyway (skipping to toplevel read/eval/print loop). 1: [QUIT ] Quit SBCL (calling #'QUIT, killing the process).

Change History (4)

comment:1 Changed 16 years ago by gwright@…

Status: newassigned
Summary: BUG: sbcl-0.8.16 BUG: sbcl-0.8.16

I can't do much with the information provided. sbcl-0.8.16 build without trouble on my OS X 10.3.6 system. Could you provide a your system type (hardware platform and OS version) and the compressed output of "sudo port -dv install sbcl". Thanks.

comment:2 Changed 16 years ago by bugs@…

severity: criticalminor
Summary: BUG: sbcl-0.8.16BUG: sbcl-0.8.16

The problem was caused by an old .sbclrc file which included (require 'asdf). So, should a new build really be reading a user's config file by default?

comment:3 Changed 16 years ago by lars@…

You should be able to avoid this problem by adding --userinit /dev/null --siteinit /dev/null to this line in the portfile:

set host_lisp "\"${workpath}/${name}-${bootversion}-powerpc-darwin/src/runtime/sbcl --core $ {workpath}/${name}-${bootversion}-powerpc-darwin/output/sbcl.core --disable-debugger\" "

comment:4 Changed 15 years ago by gwright@…

Resolution: fixed
Status: assignedclosed

This bug has been fixed for the latest portfile.

-Greg

Note: See TracTickets for help on using tickets.