Opened 11 years ago

Closed 11 years ago

#23928 closed defect (duplicate)

opendx autoreconf failure: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)

Reported by: morasta@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: opendx

Description

I've tried installing OpenDX on MacPorts 1.8.2 using the following command:

sudo port install opendx

Things happen, it appears to be working fine, then I get the following (when passed through -d):

--->  Extracting dx-4.4.4.tar.gz
DEBUG: setting option extract.args to /opt/local/var/macports/distfiles/opendx/dx-4.4.4.tar.gz
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_opendx/work" && /usr/bin/gzip -dc /opt/local/var/macports/distfiles/opendx/dx-4.4.4.tar.gz | /usr/bin/gnutar --no-same-owner -xf -'
DEBUG: Executing org.macports.patch (opendx)
--->  Configuring opendx
DEBUG: Using compiler 'Mac OS X gcc 4.2'
DEBUG: Executing org.macports.configure (opendx)
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_opendx/work/dx-4.4.4" && autoreconf --install -fv'
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force 
configure.ac:222: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)
../../lib/autoconf/lang.m4:316: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2645: AC_LINK_IFELSE is expanded from...
/opt/local/share/aclocal/libtool.m4:1022: _LT_SYS_MODULE_PATH_AIX is expanded from...
/opt/local/share/aclocal/libtool.m4:5340: _LT_LANG_CXX_CONFIG is expanded from...
/opt/local/share/aclocal/libtool.m4:785: _LT_LANG is expanded from...
/opt/local/share/aclocal/libtool.m4:768: LT_LANG is expanded from...
../../lib/autoconf/c.m4:667: AC_LANG_COMPILER(C++) is expanded from...
../../lib/autoconf/lang.m4:316: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2573: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:598: AS_IF is expanded from...
../../lib/m4sugar/m4sh.m4:346: AS_REQUIRE is expanded from...
../../lib/autoconf/general.m4:183: AC_REQUIRE_SHELL_FN is expanded from...
../../lib/autoconf/headers.m4:129: _AC_CHECK_HEADER_MONGREL is expanded from...
../../lib/autoconf/headers.m4:67: AC_CHECK_HEADER is expanded from...
../../lib/m4sugar/m4sh.m4:566: AS_FOR is expanded from...
../../lib/autoconf/headers.m4:249: AC_CHECK_HEADERS is expanded from...
configure.ac:222: the top level
autom4te: /opt/local/bin/gm4 failed with exit status: 1
aclocal: /opt/local/bin/autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
Error: Target org.macports.configure returned: autoreconf failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_opendx/work/dx-4.4.4" && autoreconf --install -fv " returned error 1
DEBUG: Backtrace: autoreconf failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_opendx/work/dx-4.4.4" && autoreconf --install -fv " returned error 1
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for opendx): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Tried checking what I could tell was happening from that and I couldn't determine what the problem was exactly. A search of older tickets likewise turned nothing up.

Attachments (2)

Portfile.diff (392 bytes) - added by kobayos@… 11 years ago.
use_autoreconf is changed from "yes" to "no"
Portfile.2.diff (309 bytes) - added by kobayos@… 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by morasta@…

Cc: morasta@… added

Cc Me!

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Cc: morasta@… removed
Keywords: opendx removed
Owner: changed from macports-tickets@… to gwright@…
Port: opendx added

Changed 11 years ago by kobayos@…

Attachment: Portfile.diff added

use_autoreconf is changed from "yes" to "no"

comment:3 Changed 11 years ago by kobayos@…

I don't know what is happening while building, however, it is possible to install by small modification of Portfile anyway. I attached a pach file for the modification. Please check it.

comment:4 Changed 11 years ago by morasta@…

Apologies for the slow reply, I've been away.

Just applied the patch using:

cd $(port dir opendx)
sudo patch -p0 < ~/Desktop/Portfile.diff

I got the following warnings I thought I should share:

--->  Staging opendx into destroot
Warning: violation by /opt/local/dx
Warning: opendx violates the layout of the ports-filesystems!
Warning: Please fix or indicate this misbehavior (if it is intended), it will be an error in future releases!
--->  Installing opendx @4.4.4_2
--->  Activating opendx @4.4.4_2
--->  Cleaning opendx

Now I tried to run opendx but can't seem to get it to work. Where should this be dumping the files/app?

comment:5 in reply to:  4 ; Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: opendx fails to install - autoreconf failureopendx autoreconf failure: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)

Replying to kobayos@…:

I don't know what is happening while building, however, it is possible to install by small modification of Portfile anyway. I attached a pach file for the modification. Please check it.

What's happening is that autoreconf is failing. "use_autoreconf yes" was added to the port in r43754 by Jeremy, "to find X11 libs on Leopard", but I wonder if that was to find Apple's X11 libs; if so, that's irrelevant now as we use MacPorts' X11 libs. In that case removing this line is probably fine. Someone on Leopard should confirm that it still builds without that line.

Replying to morasta@…:

Now I tried to run opendx but can't seem to get it to work.

Why not? What happens?

Where should this be dumping the files/app?

"port contents opendx" tells you where opendx installs files.

comment:6 in reply to:  4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to morasta@…:

Warning: violation by /opt/local/dx

The mtree violation is now filed as its own ticket in #24280.

Changed 11 years ago by kobayos@…

Attachment: Portfile.2.diff added

comment:7 in reply to:  5 Changed 11 years ago by kobayos@…

Replying to ryandesign@…:

Replying to kobayos@…:

I don't know what is happening while building, however, it is possible to install by small modification of Portfile anyway. I attached a pach file for the modification. Please check it.

What's happening is that autoreconf is failing. "use_autoreconf yes" was added to the port in r43754 by Jeremy, "to find X11 libs on Leopard", but I wonder if that was to find Apple's X11 libs; if so, that's irrelevant now as we use MacPorts' X11 libs. In that case removing this line is probably fine. Someone on Leopard should confirm that it still builds without that line.

Replying to morasta@…:

Now I tried to run opendx but can't seem to get it to work.

Why not? What happens?

Where should this be dumping the files/app?

"port contents opendx" tells you where opendx installs files.

I confirmed that this package can be built on Leopard with the attached patch file "Portfile2.diff".

comment:8 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.