Opened 11 years ago

Closed 11 years ago

#23932 closed defect (duplicate)

dsniff not installing on Snow Leopard 10.6.2

Reported by: olgashort@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: dsniff

Description (last modified by mf2k (Frank Schima))

Trying to install dsniff. Got an error to do with libnet so i uninstalled all ports and started again. I still get the following error when i try and install:

--->  Computing dependencies for dsniff
--->  Building dsniff
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/work/dsniff-2.3" && /usr/bin/make -j2 all " returned error 2
Command output: ./arpspoof.c: In function 'arp_find':
./arpspoof.c:114: warning: passing argument 2 of 'arp_cache_lookup' from incompatible pointer type
./arpspoof.c: In function 'main':
./arpspoof.c:181: warning: assignment makes pointer from integer without a cast
./dnsspoof.c: In function 'dns_init':
./dnsspoof.c:95: warning: assignment makes pointer from integer without a cast
./dnsspoof.c: In function 'dns_spoof':
./dnsspoof.c:191: error: dereferencing pointer to incomplete type
make: *** [arpspoof.o] Error 1
make: *** Waiting for unfinished jobs....
./dnsspoof.c:213: error: 'IP_H' undeclared (first use in this function)
./dnsspoof.c:213: error: (Each undeclared identifier is reported only once
./dnsspoof.c:213: error: for each function it appears in.)
./dnsspoof.c:213: error: 'UDP_H' undeclared (first use in this function)
./dnsspoof.c:236: error: 'PRu16' undeclared (first use in this function)
./dnsspoof.c:237: error: dereferencing pointer to incomplete type
./dnsspoof.c:238: error: dereferencing pointer to incomplete type
./dnsspoof.c:241: warning: passing argument 3 of 'libnet_build_udp' makes integer from pointer without a cast
./dnsspoof.c:241: error: too few arguments to function 'libnet_build_udp'
./dnsspoof.c:252: warning: passing argument 1 of 'libnet_do_checksum' from incompatible pointer type
./dnsspoof.c:252: warning: passing argument 2 of 'libnet_do_checksum' makes pointer from integer without a cast
./dnsspoof.c:252: error: too few arguments to function 'libnet_do_checksum'
./dnsspoof.c:258: error: dereferencing pointer to incomplete type
./dnsspoof.c:259: error: dereferencing pointer to incomplete type
./dnsspoof.c:260: warning: format '%s' expects type 'char *', but argument 3 has type 'int'
./dnsspoof.c:260: warning: format '%s' expects type 'char *', but argument 5 has type 'int'
./dnsspoof.c: In function 'main':
./dnsspoof.c:304: warning: format '%s' expects type 'char *', but argument 6 has type 'int'
./dnsspoof.c:316: error: too few arguments to function 'libnet_seed_prand'
make: *** [dnsspoof.o] Error 1

Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)
Port: dsniff added
Summary: Dsniff not installing on Snow Leapard 10.6.2Dsniff not installing on Snow Leopard 10.6.2

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Summary: Dsniff not installing on Snow Leopard 10.6.2dsniff not installing on Snow Leopard 10.6.2

I can't get to the error you're reporting because it is not possible to install dsniff's dependencies. dsniff depends on libnet, and on libnids which depends on libnet11, and libnet and libnet11 conflict; see #12321 and #23665.

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #23971 (it has more detailed logs).

Note: See TracTickets for help on using tickets.