Opened 12 years ago

Closed 7 years ago

#23968 closed defect (wontfix)

kio_http seg faults when attempting ssl connection

Reported by: garrisonstuber@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: MacPorts@…, mkae (Marko Käning), NicosPavlov
Port: kdelibs3

Description

Programs that rely on kio_http (Konqueror, KMyMoney) get a "protocol died unexpectedly" error when attempting to establish a https connection. Debug output from kio_http shows a segv error in libkio.

I have verified the SSL settings using kcontrol. I've tried online banking in KMyMoney, as well as variety of different SSL sites in Konqueror, all with the same results. OpenSSL is installed and appears to work.

I'd report this to the KDE guys, but it seems to be specific to the MacPorts environment. Mac is running Snow Leopard 10.6.2

I tried pasting the debug output but it was indecipherable. I've attached it instead.

Attachments (1)

kio_http_crash.txt (6.2 KB) - added by garrisonstuber@… 12 years ago.
Debug Log of Crash

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by garrisonstuber@…

Attachment: kio_http_crash.txt added

Debug Log of Crash

comment:1 Changed 12 years ago by garrisonstuber@…

Cc: garrisonstuber@… added

Cc Me!

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Cc: garrisonstuber@… removed
Keywords: kde https segv removed

You don't need to be in cc when you are the reporter.

comment:3 Changed 12 years ago by MacPorts@…

Cc: MacPorts@… added

Cc Me!

comment:4 Changed 11 years ago by michaelsbaxter@…

I have exactly the same behavior. I'm running OS 10.6.6. I performed a fresh install of kmymoney 1.0.5 via MacPorts. It complied everything under the sun over a couple hours with no reported errors, very impressive! However, I get exactly the same error as reported on this ticket. I traced it to the same place as described above in the attached crash log. Let me know if it's interesting and I'll produce a crash log to attach. I'd love to be able to use more the KDE programs on OSX once this is fixed... Great work on MacPorts.

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Port: kdelibs3 added; kde removed

I'm assuming kio_http actually comes from kdelibs3?

comment:6 Changed 10 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:7 Changed 7 years ago by jmroot (Joshua Root)

Cc: nicos@… added
Resolution: wontfix
Status: newclosed

kdelibs3 has been replaced by kdelibs4.

Note: See TracTickets for help on using tickets.