Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#24090 closed defect (fixed)

Broken (and outdated) kdeedu4 blocks digiKam update

Reported by: rechner@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: sharky@…, jgosmann (Jan Gosmann), lang@…
Port: kdeedu4

Description

About a week ago I tried to update my digiKam 1.0rc to the current version 1.1, for which macports provides a Portfile.

I tried "port selfupdate; port upgrade outdated", and waited...

Some minor errors occurred (like a port saying it could not be installed, because there were files in the way that did not belong to any registered port), but what ultimately caused me to give up was a problem with kdeedu4. I had uninstalled all the KDE ports, and digiKam depends on kdeedu4, so this had to be reinstalled. I'm surprised most of the KDE Ports are from the current KDE 4.4.1, but kdeedu4 is still at version 4.3.5. What I had installed from about three months ago was version 4.3.4.

One problem with kdeedu4 is described in ticket #23720, and I solved that by using Jan's "opengl-on-mac.patch" (thanks for that!).

Still compiling kdeedu4 failed at 97%:

[ 97%] Building CXX object step/stepcore/CMakeFiles/stepcore.dir/rigidbody.o
[...]
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeedu4/work/kdeedu-4.3.5/step/stepcore/rigidbody.cc:346:   instantiated from here
/opt/local/include/eigen2/Eigen/StdVector:124: error: '_M_erase_at_end' is not a member of 'std::std_vector<Eigen::Matrix<double, 2, 1, 2, 2, 1>, Eigen::aligned_allocator<Eigen::Matrix<double, 2, 1, 2, 2, 1> > >'
make[2]: *** [step/stepcore/CMakeFiles/stepcore.dir/rigidbody.o] Error 1
make[1]: *** [step/stepcore/CMakeFiles/stepcore.dir/all] Error 2
make: *** [all] Error 2

I tried using kdeedu4 4.4.1 instead, by using an updated local Portfile, but as far as I can see the same error occurred.

So I wonder how people actually use the new digiKam Port. Do you keep your old kdeedu4, compiled against older Versions of "eigen" and qt4-mac?

Attachments (2)

Portfile (1.1 KB) - added by jgosmann (Jan Gosmann) 11 years ago.
Portfile for kdeedu4 4.4.1
kdeedu4.log.zip (126.3 KB) - added by lang@… 11 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Cc: sharky@… added
Keywords: kde4 kdeedu4 digikam removed
Owner: changed from macports-tickets@… to snc@…
Port: kdeedu4 added

comment:2 Changed 11 years ago by lang@…

Cc: lang@… added

Cc Me!

Changed 11 years ago by jgosmann (Jan Gosmann)

Attachment: Portfile added

Portfile for kdeedu4 4.4.1

comment:3 Changed 11 years ago by jgosmann (Jan Gosmann)

After applying the opengl-on-mac patch I had no problems building kdeedu4 using the portfile which I just attached.

comment:4 in reply to:  3 Changed 11 years ago by lang@…

Replying to jan@…:

After applying the opengl-on-mac patch I had no problems building kdeedu4 using the portfile which I just attached.

I have the same problem as rechner.
After applying the opengl-on-mac patch I tried the attached portfile, but still kdeedu4 fails to build.
The failure message looks pretty much the same as the one given by rechner.
I attach the debug log (Mac OS X Version: 10.5, Xcode version: 3.1).

Changed 11 years ago by lang@…

Attachment: kdeedu4.log.zip added

comment:5 Changed 11 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: newclosed

Updated in r65562.

comment:6 in reply to:  5 Changed 11 years ago by rechner@…

Replying to snc@…:

Updated in r65562.

Ok, so kdeedu4 is no longer outdated, but for me it is still broken (just like for "lang").

Maybe the problem is caused by either the operating system (I'm also using 10.5), or by the architecture (PPC in my case)?

But I just managed to install digiKam 1.1 by modifying the Portfile so it does not depend on kdeedu4 anymore - I don't have any geo-location aware hardware anyway. Maybe the dependency could be removed for digiKam 1.2 (which is due tomorrow) as well?

That would not fix the problem with "kdeedu4" and "eigen", though.

comment:7 Changed 11 years ago by lang@…

I can once again confirm the problem of "rechner": I removed all KDE ports and reinstalled them (without problems). Still kdeedu4 will not build afterwards (same error message as we have seen). B.t.w.: I am building on a MacBook Pro (Intel).

I think deleting the dependency from kdeedu4 in the digikam portfile is a reasonable workaround for the time being. But I am really looking forward to a solution of the underlying problem -- any suggestions on how to proceed?

comment:8 Changed 11 years ago by jgosmann (Jan Gosmann)

Because of these problems I will remove kdeedu4 from the default variant of digikam and add another variant with this dependency. I think, I will update the digikam Portfile to version 1.2 in the next few days.

comment:9 Changed 11 years ago by rechner@…

@Jan: don't you think it would be enough to just write a note in the digiKam port description, instead of adding a variant? Something like:

"If you want geo-location functionality in digiKam, install the kdeedu4 port before installing digikam!"

comment:10 Changed 11 years ago by jgosmann (Jan Gosmann)

I think a variant is a little bit more comfortable, because it ensures automatically that kdeedu4 will be installed before digikam. But I am relatively new to the MacPorts project and don't know whether there is any best practice or so in cases like these.

Note: See TracTickets for help on using tickets.