Opened 11 years ago

Closed 10 years ago

#24091 closed defect (duplicate)

help2man build error while installing g95

Reported by: ryan.manger@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: help2man

Description

Computer: MBPro OS X 10.4.11

Tried installing g95, but received an error about dependencies. I began to install the individual dependencies, but ran into a problem with help2man.

Any suggestions/solutions will be greatly appreciated.

Thank you,

Ryan

Here is what happens when I try installing g95:

dyn21924543:~ Ryan$ sudo port -d install g95
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/g95
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/g95
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: 'universal_variant no' specified, so not adding the default universal variant
DEBUG: Requested variant darwin is not provided by port g95.
DEBUG: Requested variant i386 is not provided by port g95.
DEBUG: Requested variant macosx is not provided by port g95.
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: epoch: in tree: 0 installed: 0
DEBUG: libiconv 1.13.1_0 exists in the ports tree
DEBUG: libiconv 1.13.1_0  is the latest installed
DEBUG: libiconv 1.13.1_0  is active
DEBUG: Merging existing variants  into variants
DEBUG: new fully merged portvariants: 
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port libiconv.
DEBUG: Requested variant i386 is not provided by port libiconv.
DEBUG: Requested variant macosx is not provided by port libiconv.
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gperf
DEBUG: epoch: in tree: 0 installed: 0
DEBUG: gperf 3.0.4_0 exists in the ports tree
DEBUG: gperf 3.0.4_0  is the latest installed
DEBUG: gperf 3.0.4_0  is active
DEBUG: Merging existing variants  into variants
DEBUG: new fully merged portvariants: 
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gperf
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port gperf.
DEBUG: Requested variant i386 is not provided by port gperf.
DEBUG: Requested variant macosx is not provided by port gperf.
DEBUG: No need to upgrade! gperf 3.0.4_0 >= gperf 3.0.4_0
DEBUG: No need to upgrade! libiconv 1.13.1_0 >= libiconv 1.13.1_0
--->  Computing dependencies for g95
DEBUG: Searching for dependency: libtool
DEBUG: Didn't find receipt, going to depspec regex for: libtool
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libtool
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libtool
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: adding the default universal variant
DEBUG: Requested variant i386 is not provided by port libtool.
DEBUG: Requested variant macosx is not provided by port libtool.
DEBUG: Executing variant darwin provides darwin
DEBUG: Searching for dependency: libiconv
DEBUG: Found Dependency: receipt exists for libiconv
DEBUG: Searching for dependency: odcctools
DEBUG: Didn't find receipt, going to depspec regex for: odcctools
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/odcctools
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/odcctools
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Requested variant darwin is not provided by port odcctools.
DEBUG: Requested variant i386 is not provided by port odcctools.
DEBUG: Requested variant macosx is not provided by port odcctools.
DEBUG: Searching for dependency: automake
DEBUG: Didn't find receipt, going to depspec regex for: automake
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/automake
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/automake
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Requested variant darwin is not provided by port automake.
DEBUG: Requested variant i386 is not provided by port automake.
DEBUG: Requested variant macosx is not provided by port automake.
DEBUG: Searching for dependency: perl5
DEBUG: Found Dependency: receipt exists for perl5
DEBUG: Searching for dependency: autoconf
DEBUG: Didn't find receipt, going to depspec regex for: autoconf
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/autoconf
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/autoconf
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: 'universal_variant no' specified, so not adding the default universal variant
DEBUG: Requested variant darwin is not provided by port autoconf.
DEBUG: Requested variant i386 is not provided by port autoconf.
DEBUG: Requested variant macosx is not provided by port autoconf.
DEBUG: Searching for dependency: perl5
DEBUG: Found Dependency: receipt exists for perl5
DEBUG: Searching for dependency: m4
DEBUG: Found Dependency: receipt exists for m4
DEBUG: Searching for dependency: help2man
DEBUG: Didn't find receipt, going to depspec regex for: help2man
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/help2man
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/help2man
DEBUG: OS Platform: darwin
DEBUG: OS Version: 8.11.1
DEBUG: Mac OS X Version: 10.4
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Requested variant darwin is not provided by port help2man.
DEBUG: Requested variant i386 is not provided by port help2man.
DEBUG: Requested variant macosx is not provided by port help2man.
DEBUG: Searching for dependency: perl5
DEBUG: Found Dependency: receipt exists for perl5
DEBUG: Searching for dependency: p5-locale-gettext
DEBUG: Found Dependency: receipt exists for p5-locale-gettext
DEBUG: Searching for dependency: gettext
DEBUG: Found Dependency: receipt exists for gettext
DEBUG: Searching for dependency: libiconv
DEBUG: Found Dependency: receipt exists for libiconv
DEBUG: Searching for dependency: subversion
DEBUG: Found Dependency: receipt exists for subversion
DEBUG: Executing org.macports.main (help2man)
DEBUG: Skipping completed org.macports.fetch (help2man)
DEBUG: Skipping completed org.macports.checksum (help2man)
DEBUG: Skipping completed org.macports.extract (help2man)
DEBUG: Skipping completed org.macports.patch (help2man)
DEBUG: Skipping completed org.macports.configure (help2man)
--->  Building help2man
DEBUG: Executing org.macports.build (help2man)
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.4'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && /usr/bin/make -j2 all'
/usr/bin/gcc-4.0  -o bindtextdomain.so -fPIC -bundle -L/opt/local/lib bindtextdomain.c -lintl 
bindtextdomain.c: In function 'setup':
bindtextdomain.c:42: error: 'RTLD_NEXT' undeclared (first use in this function)
bindtextdomain.c:42: error: (Each undeclared identifier is reported only once
bindtextdomain.c:42: error: for each function it appears in.)
make: *** [bindtextdomain.so] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && /usr/bin/make -j2 all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && /usr/bin/make -j2 all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for help2man): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: The following dependencies failed to build: libtool automake autoconf help2man odcctools
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (7)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to takeshi@…
Port: g95 added

Please remember to fill in the Port field and cc the maintainer.

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from takeshi@… to macports-tickets@…
Port: help2man added; g95 removed

This is a problem with help2man.

comment:3 Changed 11 years ago by mf2k (Frank Schima)

Summary: g95 fails to installhelp2man build error while installing g95

comment:4 Changed 11 years ago by ryan.manger@…

Problem is solved. For anyone trying to install g95 on 10.4.11, install g95 binaries from http://www.g95.org/downloads.shtml, following the instructions in the manual. Also, you may run into a problem with libiconv.2.dylib. To fix that problem, refer to:

http://www.bill.eccles.net/bills_words/2008/12/libiconv-madness.html

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: closedreopened

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually a duplicate of #12336.

Note: See TracTickets for help on using tickets.