Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#24207 closed defect (duplicate)

emacs-app does not compile on Snow Leopard

Reported by: grossi@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: emacs-app

Description (last modified by jmroot (Joshua Root))

This is what I get... thanks -Roberto

DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/aqua/emacs-app
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/aqua/emacs-app
DEBUG: OS Platform: darwin
DEBUG: OS Version: 10.2.0
DEBUG: Mac OS X Version: 10.6
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Requested variant darwin is not provided by port emacs-app.
DEBUG: Requested variant i386 is not provided by port emacs-app.
DEBUG: Requested variant macosx is not provided by port emacs-app.
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/ncurses
DEBUG: epoch: in tree: 0 installed: 0
DEBUG: ncurses 5.7_0 exists in the ports tree
DEBUG: ncurses 5.7_0 +darwin_10 is the latest installed
DEBUG: ncurses 5.7_0 +darwin_10 is active
DEBUG: Merging existing variants darwin_10 into variants
DEBUG: new fully merged portvariants: 
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/ncurses
DEBUG: OS Platform: darwin
DEBUG: OS Version: 10.2.0
DEBUG: Mac OS X Version: 10.6
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port ncurses.
DEBUG: Requested variant i386 is not provided by port ncurses.
DEBUG: Requested variant macosx is not provided by port ncurses.
DEBUG: Executing variant darwin_10 provides darwin_10
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/ncursesw
DEBUG: epoch: in tree: 0 installed: 0
DEBUG: ncursesw 5.7_0 exists in the ports tree
DEBUG: ncursesw 5.7_0 +darwin_10 is the latest installed
DEBUG: ncursesw 5.7_0 +darwin_10 is active
DEBUG: Merging existing variants darwin_10 into variants
DEBUG: new fully merged portvariants: 
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/ncursesw
DEBUG: OS Platform: darwin
DEBUG: OS Version: 10.2.0
DEBUG: Mac OS X Version: 10.6
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port ncursesw.
DEBUG: Requested variant i386 is not provided by port ncursesw.
DEBUG: Requested variant macosx is not provided by port ncursesw.
DEBUG: Executing variant darwin_10 provides darwin_10
DEBUG: No need to upgrade! ncursesw 5.7_0 >= ncursesw 5.7_0
DEBUG: No need to upgrade! ncurses 5.7_0 >= ncurses 5.7_0
--->  Computing dependencies for emacs-app
DEBUG: Searching for dependency: ncurses
DEBUG: Found Dependency: receipt exists for ncurses
DEBUG: Executing org.macports.main (emacs-app)
DEBUG: Skipping completed org.macports.fetch (emacs-app)
DEBUG: Skipping completed org.macports.checksum (emacs-app)
DEBUG: setting option extract.cmd to /usr/bin/bzip2
DEBUG: Skipping completed org.macports.extract (emacs-app)
DEBUG: Skipping completed org.macports.patch (emacs-app)
DEBUG: Skipping completed org.macports.configure (emacs-app)
--->  Building emacs-app
DEBUG: Executing org.macports.build (emacs-app)
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_emacs-app/work/emacs-23.1" && /usr/bin/make -j2 all'
cd lib-src; /usr/bin/make all - --jobserver-fds=6,7 -j                           \
	  CC='/usr/bin/gcc-4.2' CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' \
	  LDFLAGS='-L/opt/local/lib' MAKE='/usr/bin/make'
make[1]: Nothing to be done for `all'.
boot=bootstrap-emacs;                         \
	if [ ! -x "src/$boot" ]; then                                     \
	    cd src; /usr/bin/make all - --jobserver-fds=6,7 -j                                   \
	      CC='/usr/bin/gcc-4.2' CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include'         \
	      LDFLAGS='-L/opt/local/lib' MAKE='/usr/bin/make' BOOTSTRAPEMACS="$boot"; \
	fi;
/usr/bin/gcc-4.2 -c -I/opt/local/include -Demacs -DHAVE_CONFIG_H  -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_emacs-app/work/emacs-23.1/src -Dtemacs   -I/opt/local/include/dbus-1.0 -I/opt/local/lib/dbus-1.0/include -O2 -arch x86_64 nsterm.m
/usr/bin/gcc-4.2 -c -I/opt/local/include -Demacs -DHAVE_CONFIG_H  -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_emacs-app/work/emacs-23.1/src -Dtemacs   -I/opt/local/include/dbus-1.0 -I/opt/local/lib/dbus-1.0/include -O2 -arch x86_64 nsfns.m
In file included from nsterm.h:20,
                 from nsfns.m:37:
dispextern.h:1250: error: array type has incomplete element type
In file included from nsterm.h:20,
                 from nsterm.m:41:
dispextern.h:1250: error: array type has incomplete element type
nsterm.m: In function 'ns_get_color':
nsterm.m:1429: warning: format '%x' expects type 'unsigned int *', but argument 3 has type 'long long unsigned int *'
nsterm.m: In function 'ns_color_to_lisp':
nsterm.m:1574: warning: passing argument 1 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1574: warning: passing argument 2 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1574: warning: passing argument 3 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1574: warning: passing argument 4 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1578: warning: passing argument 1 of 'getWhite:alpha:' from incompatible pointer type
nsterm.m:1578: warning: passing argument 2 of 'getWhite:alpha:' from incompatible pointer type
nsterm.m:1579: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m:1579: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m:1579: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m:1585: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m:1585: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m:1585: warning: '0' flag ignored with precision and '%x' printf format
nsterm.m: In function 'ns_query_color':
nsterm.m:1603: warning: passing argument 1 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1603: warning: passing argument 2 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1603: warning: passing argument 3 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m:1603: warning: passing argument 4 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m: In function 'note_mouse_movement':
nsterm.m:1768: warning: passing argument 4 of 'remember_mouse_glyph' from incompatible pointer type
nsterm.m: In function 'ns_mouse_position':
nsterm.m:1837: warning: passing argument 4 of 'remember_mouse_glyph' from incompatible pointer type
nsfns.m: In function 'Fxw_color_values':
nsfns.m:2252: warning: passing argument 1 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsfns.m:2252: warning: passing argument 2 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsfns.m:2252: warning: passing argument 3 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsfns.m:2252: warning: passing argument 4 of 'getRed:green:blue:alpha:' from incompatible pointer type
nsterm.m: In function 'ns_get_glyph_string_clip_rect':
nsterm.m:2554: error: dereferencing pointer to incomplete type
nsterm.m:2554: error: dereferencing pointer to incomplete type
nsterm.m:2557: error: dereferencing pointer to incomplete type
nsterm.m:2557: error: invalid use of undefined type 'struct _NSRect'
nsterm.m:2557: error: dereferencing pointer to incomplete type
nsterm.m: In function 'ns_dumpglyphs_stretch':
nsterm.m:2925: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
make[1]: *** [nsfns.o] Error 1
make[1]: *** Waiting for unfinished jobs....
nsterm.m: In function 'ns_draw_glyph_string':
nsterm.m:3009: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
nsterm.m:3026: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
nsterm.m:3038: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
nsterm.m:3050: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
nsterm.m:3083: warning: passing argument 2 of 'ns_get_glyph_string_clip_rect' from incompatible pointer type
nsterm.m: In function '-[EmacsView keyDown:]':
nsterm.m:4611: warning: 'wantsToDelayTextChangeNotifications' is deprecated (declared at /System/Library/Frameworks/AppKit.framework/Headers/NSInputManager.h:112)
nsterm.m: In function '-[EmacsView characterIndexForPoint:]':
nsterm.m:4820: warning: conflicting types for '-(unsigned int)characterIndexForPoint:(NSPoint)thePoint'
/System/Library/Frameworks/AppKit.framework/Headers/NSInputManager.h:45: warning: previous declaration of '-(NSUInteger)characterIndexForPoint:(NSPoint)thePoint'
nsterm.m: In function '-[EmacsView initFrameFromEmacs:]':
nsterm.m:5219: warning: class 'EmacsView' does not implement the 'NSWindowDelegate' protocol
nsterm.m: In function '-[EmacsView draggingEntered:]':
nsterm.m:5497: warning: conflicting types for '-(unsigned int)draggingEntered:(id <NSDraggingInfo>)sender'
/System/Library/Frameworks/AppKit.framework/Headers/NSDragging.h:56: warning: previous declaration of '-(NSDragOperation)draggingEntered:(id <NSDraggingInfo>)sender'
nsterm.m: In function '+[EmacsScroller scrollerWidth]':
nsterm.m:5782: warning: conflicting types for '+(float)scrollerWidth'
/System/Library/Frameworks/AppKit.framework/Headers/NSScroller.h:76: warning: previous declaration of '+(CGFloat)scrollerWidth'
nsterm.m: In function '-[EmacsScroller setPosition:portion:whole:]':
nsterm.m:5912: warning: 'setFloatValue:knobProportion:' is deprecated (declared at /System/Library/Frameworks/AppKit.framework/Headers/NSScroller.h:107)
nsterm.m:5919: warning: 'setFloatValue:knobProportion:' is deprecated (declared at /System/Library/Frameworks/AppKit.framework/Headers/NSScroller.h:107)
nsterm.m: In function '-[EmacsScroller mouseDown:]':
nsterm.m:6024: warning: format '%d' expects type 'int', but argument 3 has type 'NSScrollerPart'
make[1]: *** [nsterm.o] Error 1
make: *** [src] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_emacs-app/work/emacs-23.1" && /usr/bin/make -j2 all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_emacs-app/work/emacs-23.1" && /usr/bin/make -j2 all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for emacs-app): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to css@…
Port: emacs-app added

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #20936, please search before filing new tickets.

comment:3 in reply to:  2 Changed 10 years ago by grossi@…

Replying to jmr@…:

Duplicate of #20936, please search before filing new tickets.

Thanks it works. Sorry I did not find the previous ticket using Google. -Roberto

Note: See TracTickets for help on using tickets.