Opened 10 years ago

Closed 10 years ago

#24248 closed defect (fixed)

macfuse: build failed

Reported by: scurippio@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: macfuse

Description (last modified by jmroot (Joshua Root))

Check dependencies
** BUILD FAILED **


The following build commands failed:
load_fusefs:
        Ld /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_macfuse/work/core/10.6/fusefs/build/fusefs.build/Release/load_fusefs.build/Objects-normal/ppc/load_fusefs normal ppc
mount_fusefs:
        Ld /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_macfuse/work/core/10.6/fusefs/build/fusefs.build/Release/mount_fusefs.build/Objects-normal/ppc/mount_fusefs normal ppc
(2 failures)

Attachments (2)

debug.txt (160.6 KB) - added by scurippio@… 10 years ago.
Build Log
patch-10.5-to-10.6.diff (7.1 KB) - added by drkp (Dan Ports) 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by scurippio@…

Attachment: debug.txt added

Build Log

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to dports@…
Port: macfuse added

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

So the build failed but xcodebuild returned 0 for some reason, so MacPorts continued on to destroot, and only eventually realised something was wrong because no files were installed. The confusing part is that you're apparently building for ppc on 10.6.

comment:3 Changed 10 years ago by scurippio@…

I have a macbook pro unibody with up to date snow leopard (10.6.2), and I use default macports configuration files. Thus I have no problems installing any other ports.

Thank you.

comment:4 Changed 10 years ago by drkp (Dan Ports)

IIRC, the macfuse installation scripts try to build what's basically a universal binary for certain parts of the installation (parts of the userland; the kernel extension is 32-bit only). It obviously shouldn't be trying to build ppc on 10.6, though.

I haven't seen this before; I'm trying to reproduce it.

comment:5 Changed 10 years ago by drkp (Dan Ports)

I still can't reproduce your build failure. But I did find some problems with the port's project files -- it links against the 10.5 SDK when it's building for 10.6. This obviously isn't right, and I'll post a patch to fix that.

The other interesting thing is that, for the parts that get built by xcode (this the kernel module and mount_fusefs/load_fusefs utils; not the libfuse library that filesystems link against), it uses the xcode "32/64-bit Universal" configuration, which builds ppc, i386, and x86_64. I'm thinking that it should only build i386 on 10.6: reports from upstream are that 64-bit kernel support is broken, and ppc isn't supported for 10.6.

Although we shouldn't be doing it, I'm surprised that you get linker errors when trying to link a ppc binary against the 10.5 SDK, since it works fine for me on both 32-bit and 64-bit 10.6 machines.

comment:6 Changed 10 years ago by drkp (Dan Ports)

Updated patchfile is attached. This replaces files/patch-10.5-to-10.6.diff. For 10.6 builds, this causes it to link against the 10.6 SDK and builds the kernel module only for i386. libfuse and MacFuse.framework still build universal.

Works for me on 32-bit and 64-bit machines running 10.6. It shouldn't affect 10.5 builds at all, though I don't have a 10.5 machine handy to test that.

(For the record, the changes to 10.6/fusefs/fusefs.xcodeproj/project.pbxproj are the changed part of the patchfile. I find patches to patchfiles impossible to read, so I'm just uploading the patchfile itself.)

Changed 10 years ago by drkp (Dan Ports)

Attachment: patch-10.5-to-10.6.diff added

comment:7 Changed 10 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

r67203. Sorry for the delay.

Note: See TracTickets for help on using tickets.