Opened 9 years ago

Closed 8 years ago

#24383 closed defect (fixed)

python26 does not enforce build_arch

Reported by: bletofarine@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: python26

Description

I'm running MacOSX 10.6.3 with an up-to-date port tree.

In order to build a i386-only python, I set my build_arch flag to i386 in my macports.conf file.

Unfortunately, it does not work. I tried to perform a port clean on python26, without success.

/usr/bin/gcc-4.2 -L/opt/local/lib -u _PyMac_Error Python.framework/Versions/2.6/Python -o python.exe \
			Modules/python.o \
			 -ldl  -framework CoreFoundation     
ld: warning: in Python.framework/Versions/2.6/Python, file is not of required architecture
Undefined symbols:
  "_PyMac_Error", referenced from:
  "_Py_Main", referenced from:
      _main in python.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [python.exe] Error 1

I'm going to attach the complete build log to the ticket.

Attachments (1)

debug (112.4 KB) - added by bletofarine@… 9 years ago.
build log (sudo port -d install python26)

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by bletofarine@…

Attachment: debug added

build log (sudo port -d install python26)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Cc: mcalhoun@… added
Owner: changed from macports-tickets@… to blb@…
Summary: python26 2.6.5 does not build if macport.conf build_arch=i386python26 does not enforce build_arch

Please remember to cc the maintainers.

comment:2 Changed 9 years ago by blb@…

This would likely need some serious updates to the python build system; simpler may be to build for universal using 32&64 bit which is supposed to work for python26. Note you will need all dependencies built that way as well.

comment:3 Changed 9 years ago by bletofarine@…

Ok. I don't think that it's worth any serious updates.

comment:4 Changed 9 years ago by blb@…

Cc: mcalhoun@… removed
Owner: changed from blb@… to mcalhoun@…

comment:5 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Can't reproduce with current versions of base and the port.

comment:6 Changed 8 years ago by lhunath@…

Resolution: fixed
Status: closedreopened

I just got this with python24, should I make a separate issue?

:info:build /usr/bin/g++-4.2 -arch x86_64 -L/opt/local/lib -arch x86_64  -o python.exe \
:info:build                     Modules/ccpython.o \
:info:build                     libpython2.4.a -ldl      
:info:build Undefined symbols for architecture x86_64:
:info:build   "_Py_Main", referenced from:
:info:build       _main in ccpython.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build collect2: ld returned 1 exit status
:info:build make: *** [python.exe] Error 1
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python24/work/Python-2.4.6" && /usr/bin/make all " returned error 2

comment:7 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed

Yes, it's a different port with a different maintainer.

Note: See TracTickets for help on using tickets.