Opened 9 years ago

Closed 5 years ago

#24428 closed defect (fixed)

lmms: zynaddsubfx plugin disabled on x86_64

Reported by: matrixm@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: lmms

Description

I've run into an issue while trying to install lmms. I'm going to attach the entire build log but include the last 15-20 lines of the build below.

ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [plugins/zynaddsubfx/remote_zynaddsubfx] Error 1
make[1]: *** [plugins/zynaddsubfx/CMakeFiles/remote_zynaddsubfx.dir/all] Error 2
make: *** [all] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/work/lmms-0.4.5" && /usr/bin/make all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_lmms/work/lmms-0.4.5" && /usr/bin/make all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for lmms): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

I'm on a 1st gen MBP 10.6.3 upgraded from 10.4, using XQuartz 2.5.0 (xorg-server 1.7.6); 2GHz Intel Core Duo, 1GB Ram. Have run port selfupdate to ensure I'm at the most recent version.

Not sure what else to include or what to do to help with troubleshooting the issue.

Attachments (1)

lmms_build.log (213.8 KB) - added by matrixm@… 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by matrixm@…

Attachment: lmms_build.log added

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Looks like it's missing -framework Carbon for one thing.

comment:2 Changed 9 years ago by matrixm@…

Is that something I can add to the portfile somehow to check to see if it works (once I get home to my laptop)? Sorry for not fully comprehending, most of my experience with actual programming is a semester of C++ at a community college and some bash scripts I've written.

comment:3 Changed 9 years ago by matrixm@…

Ok, setup a local repository and copied the Portfile to it for lmms. I modified the Portfile to include -framework Carbon in the configure.args-append section. I'm no longer getting all the undefined symbols errors, but it's still not working. Now I'm getting the output listed below when it tries to run the configure:

--->  Configuring lmms
DEBUG: Using compiler 'Mac OS X gcc 4.2'
DEBUG: Executing proc-pre-org.macports.configure-configure-0
DEBUG: Executing org.macports.configure (lmms)
DEBUG: Environment: CFLAGS='-O2 -arch i386' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-O2 -arch i386' MACOSX_DEPLOYMENT_TARGET='10.6' CXX='/usr/bin/g++-4.2' F90FLAGS='-O2 -m32' LDFLAGS='-L/opt/local/lib' OBJC='/usr/bin/gcc-4.2' FCFLAGS='-O2 -m32' INSTALL='/usr/bin/install -c' OBJCFLAGS='-O2 -arch i386' FFLAGS='-O2 -m32' CC='/usr/bin/gcc-4.2'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_Users_matrixm_bin_ports_multimedia_lmms/work/lmms-0.4.5" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DWANT_VST=off -framework Carbon -DCMAKE_OSX_ARCHITECTURES="i386"'
CMake Error: The source directory "/opt/local/var/macports/build/_Users_matrixm_bin_ports_multimedia_lmms/work/lmms-0.4.5/Carbon" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_Users_matrixm_bin_ports_multimedia_lmms/work/lmms-0.4.5" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DWANT_VST=off -framework Carbon -DCMAKE_OSX_ARCHITECTURES="i386" " returned error 1
DEBUG: Backtrace: configure failure: shell command " cd "/opt/local/var/macports/build/_Users_matrixm_bin_ports_multimedia_lmms/work/lmms-0.4.5" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DWANT_VST=off -framework Carbon -DCMAKE_OSX_ARCHITECTURES="i386" " returned error 1
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for lmms): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

It looks almost like it expects Carbon to be a library that it needs to be able to load, but I can tell when I search for carbon ports that it's actually a library that the OS should provide instead. I'm willing to try any suggestions to help get this working.

comment:4 Changed 9 years ago by matrixm@…

I think I figured out what the problem was. Instead of adding -framework Carbon to the configure.args-append, I needed to create a configure.ldflags-append and list it there instead. I did that and it appears to be compiling now. I'll provide an update once it's finished if it works successfully.

comment:5 Changed 9 years ago by matrixm@…

Ok, by putting in config.ldflags-append -framework Carbon it compiled and runs successfully (although it does complain not having a midi client, it still works as far as I can tell).

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: lmms 0.4.5 undefined symbols - build errorslmms: undefined symbols relating to Carbon

I'm working on updating lmms to 0.4.6 and fixing this issue. The problem is that on 64-bit we can't use Carbon (you don't see this problem because your 1st-gen MBP is 32-bit), and I'm having problems with undefined symbols relating to samplerate.

comment:7 Changed 9 years ago by matrixm@…

I'll be willing to test it out on my 32-bit MBP if you don't have one available for your own testing once you've managed to resolve the symbol issue on the 64-bit side of things.

comment:8 Changed 9 years ago by raimue (Rainer Müller)

Summary: lmms: undefined symbols relating to Carbonlmms: zynaddsubfx plugin disabled on x86_64

In r57605 I disabled the zynaddsubfx plugin for x86_64. Version 0.4.8 contains a newer fltk which at least could be build for X11, but I didn't investigate further.

comment:9 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

I think this is no longer a problem; lmms 0.4.15 built successfully on all four buildslaves.

Note: See TracTickets for help on using tickets.