Opened 11 years ago

Closed 10 years ago

#24506 closed defect (worksforme)

freetype: error: cannot run C compiled programs

Reported by: kristjan.steinarsson@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: freetype

Description (last modified by ryandesign (Ryan Schmidt))

Hello,
I tried to install Wine on my Mac, which runs Snow Leopard. I've installed Xcode and MacPorts and then tried to install Wine. This is what I get:

--->  Computing dependencies for wine-devel
--->  Fetching freetype
--->  Verifying checksum(s) for freetype
--->  Extracting freetype
--->  Applying patches to freetype
--->  Configuring freetype
--->  Configuring freetype for architecture x86_64
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_freetype/work/freetype-2.3.12-x86_64" && ./configure --prefix=/opt/local  " returned error 2
Command output: * module: truetype  (Windows/Mac font files with extension *.ttf or *.ttc)
* module: type1     (Postscript font files with extension *.pfa or *.pfb)
* module: cff       (OpenType fonts with extension *.otf)
* module: cid       (Postscript CID-keyed fonts, no known extension)
* module: pfr       (PFR/TrueDoc font files with extension *.pfr)
* module: type42    (Type 42 font files with no known extension)
* module: winfnt    (Windows bitmap fonts with extension *.fnt or *.fon)
* module: pcf       (pcf bitmap fonts)
* module: bdf       (bdf bitmap fonts)
* module: sfnt      (helper module for TrueType & OpenType formats)
* module: autofit   (automatic hinting module)
* module: pshinter  (Postscript hinter module)
* module: raster    (monochrome bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer for LCDs)
* module: smooth    (anti-aliased bitmap renderer for vertical LCDs)
* module: otvalid   (OpenType validation module)
* module: psaux     (Postscript Type 1 & Type 2 helper module)
* module: psnames   (Postscript & Unicode Glyph name handling)
done.
cd builds/unix; ./configure  '--prefix=/opt/local'
checking build system type... i386-apple-darwin10.3.0
checking host system type... i386-apple-darwin10.3.0
checking for gcc... /usr/bin/gcc-4.2
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: in `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_freetype/work/freetype-2.3.12-x86_64/builds/unix':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
make: *** [setup] Error 1

Error: The following dependencies failed to build: fontconfig freetype libiconv gperf jpeg lcms tiff libpng libxml2 libxslt mesa glut makedepend pkgconfig xorg-xproto xorg-dri2proto xorg-glproto xorg-libXfixes xorg-fixesproto xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-libXdmcp xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXi xorg-libXext xorg-libXmu xorg-libXt xorg-libsm xorg-libice ncurses ncursesw openssl xorg-libXcomposite xorg-compositeproto xorg-libXcursor xorg-renderproto xrender xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto xorg-libXxf86vm xorg-xf86vidmodeproto
Error: Status 1 encountered during processing.

I'm a newbie when it comes to this, and would be very grateful for any assistance. I have no idea what may have gone wrong here, or how to proceed to fix it.

Change History (4)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: freetype added

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer.

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Summary: Can't install Wine because of problem with Freetypefreetype: error: cannot run C compiled programs

"error: cannot run C compiled programs" usually means you haven't installed Xcode. Please verify you've installed Xcode 3.2.2.

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Any news here? Have you been able to compile freetype by now?

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

No response; closing.

Note: See TracTickets for help on using tickets.