Opened 9 years ago

Closed 8 years ago

#24607 closed update (fixed)

please update hs-hashed-storage to 0.4.11

Reported by: yaseppochi (Stephen J. Turnbull) Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: hs-hashed-storage

Description

darcs 2.4.1 insists on it, with version equality in the dependency.

Attachments (2)

Portfile-hs-hashed-storage.diff (790 bytes) - added by josephholsten@… 9 years ago.
hs-hashed-storage-patch (2.8 KB) - added by scooter.phd@… 9 years ago.
Updated patch with corrected checksums (but otherwise, the same)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Cc: gwright@… removed
Owner: changed from macports-tickets@… to gwright@…
Type: defectupdate
Version: 1.8.99

Changed 9 years ago by josephholsten@…

comment:2 Changed 9 years ago by josephholsten@…

Please try the attached diff.

As hs-hashed-storage 0.4.11 still depends on 0.4 <= hs-mmap < 0.5, it will still be broken due to #24244.

comment:3 Changed 9 years ago by yaseppochi (Stephen J. Turnbull)

Tried the patch (which is reversed; if anybody else tries it, just use the -R flag to patch). Applies fine (with -R), but as you predicted, still broken due to hs-mmap version out of range. I don't have time to try to hack this into submission, so I'll just wait for the resolution of #24244. Thanks for looking at it!

comment:4 Changed 9 years ago by ru.w31rd0@…

I can confirm this patch works fine with mmap 0.4.1 installed (got it from http://trac.macports.org/browser/trunk/dports/devel/hs-mmap/Portfile?rev=64879).

comment:5 Changed 9 years ago by gwright@…

Status: newassigned

comment:6 Changed 9 years ago by scooter.phd@…

In the meantime, hs-hashed-storage now requires mmap >= 0.5 and < 0.6. Attached is the patch file that both updates to version 0.4.11 and handles the changes inflicted by mmap 0.5.x

comment:7 Changed 9 years ago by bastiaan@…

The checksums in hs-hashed-storage-patch are now out of date, but otherwise the patch works fine.

comment:8 in reply to:  7 Changed 9 years ago by scooter.phd@…

Replying to bastiaan@…:

The checksums in hs-hashed-storage-patch are now out of date, but otherwise the patch works fine.

It's possible that the corporate proxy unpacked the tar.gz file on the way through the firewall, which would result in different checksums.

Changed 9 years ago by scooter.phd@…

Attachment: hs-hashed-storage-patch added

Updated patch with corrected checksums (but otherwise, the same)

comment:9 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

hs-hashed-storage-04 was added at version 0.4.11 in r70394. Updated hs-hashed-storage to 0.5.6 in r78237.

Note: See TracTickets for help on using tickets.