Opened 9 years ago

Closed 8 years ago

#24649 closed defect (worksforme)

cannot build plplot 5.9.5 port on OSX 10.5.8

Reported by: matthew.l.ferguson@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: plplot

Description (last modified by jmroot (Joshua Root))

Wants the SDK version to equal the OSX version.

  System Version:	Mac OS X 10.5.8 (9L31a)
  Kernel Version:	Darwin 9.8.0
  Xcode  Version:       3.1.4
CMake Error at /opt/local/share/cmake-2.8/Modules/Platform/Darwin.cmake:140 (message):
  CMAKE_OSX_DEPLOYMENT_TARGET (10.5) is greater than CMAKE_OSX_SYSROOT SDK
  (/Developer/SDKs/MacOSX10.4u.sdk).  Please set CMAKE_OSX_DEPLOYMENT_TARGET
  to 10.4 or lower
Call Stack (most recent call first):
  /opt/local/share/cmake-2.8/Modules/Platform/Darwin.cmake:146 (SanityCheckSDKAndDeployTarget)
  /opt/local/share/cmake-2.8/Modules/CMakeSystemSpecificInformation.cmake:36 (INCLUDE)
  CMakeLists.txt:38 (project)

Attachments (1)

macports.plplot.ticket (850 bytes) - added by matthew.l.ferguson@… 9 years ago.
sudo port -d install plplot

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by matthew.l.ferguson@…

Attachment: macports.plplot.ticket added

sudo port -d install plplot

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to takeshi@…

Please remember to cc the maintainer.

comment:2 Changed 9 years ago by tenomoto (Takeshi Enomoto)

I cannot reproduce your problem on ppc Leopard. It is strange that CMAKE_OSX_DEPLOYMENT_SYSROOT is set to /Developer/SDKs/MacOSX10.4u.sdk on Leopard.

comment:3 Changed 8 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

Can't reproduce with current versions.

Note: See TracTickets for help on using tickets.