Opened 9 years ago

Closed 9 years ago

#24655 closed defect (worksforme)

Mesa-7.8.1 Make error

Reported by: grifty@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: mesa

Description

Attempting to install Mesa-7.8.1 as a prereq to wine. Running Snow Leopard 10.6.3 with XCode 3.1.4. Running 'sudo port install mesa'. Tried various variants (admittedly not know what difference they really make), such as +hw_render, +universal, all failing. Initially wasn't trying to install Mesa separately from Wine, but the Wine install was failing on Mesa, so I've just been focusing on Mesa.

Relatively new to this, so not really sure what to hone in on in the output, but I think the problem is somewhere in this:

nm: for architecture x86_64 object: /System/Library/Frameworks/OpenGL.framework/Libraries/libGL.dylib malformed object (unknown load command 5)
    while executing
"exec nm -j -g /System/Library/Frameworks/OpenGL.framework/Libraries/libGL.dylib"
    (procedure "main" line 101)
    invoked from within
"main $::argc $::argv"
    invoked from within
"exit [main $::argc $::argv]"
    (file "./gen_funcs.tcl" line 629)
    while executing
"exec $tclsh ./gen_funcs.tcl specs/gl.spec stage.3 stage.4"
    (procedure "main" line 9)
    invoked from within
"main"
    invoked from within
"exit [main]"
    (file "gen_code.tcl" line 50)
make[1]: *** [subdirs] Error 1
make: *** [default] Error 1

Attachments (1)

mesa-7.8.1 make output.txt (785.3 KB) - added by grifty@… 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by grifty@…

Attachment: mesa-7.8.1 make output.txt added

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Keywords: mesa make libGL.dylib removed
Owner: changed from macports-tickets@… to jeremyhu@…
Port: mesa added; Mesa removed

Please remember to cc the maintainer. If you are really using Xcode 3.1.4 on Snow Leopard, you need to upgrade to 3.2.x.

comment:2 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: worksforme
Status: newclosed

Yeah. Please upgrade to a recent XCode release and reopen if you have problems.

Note: See TracTickets for help on using tickets.