Opened 16 years ago

Closed 15 years ago

#2471 closed defect (duplicate)

BUG: ocaml fails on OpenDarwin/x86

Reported by: mww@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

ocaml fails on OpenDarwin/x86 with this error:

gnumake[1]: * No rule to make target none.o', needed by libasmrun.a'. Stop. gnumake: * [runtimeopt] Error 2

seems like at least openbsd/sparc64 encountered this bug also: http://monkey.org/openbsd/archive/ports/0203/msg00073.html

Attachments (6)

ocaml.log.txt (82.5 KB) - added by mww@… 16 years ago.
Logfile of the build on OpenDarwin-7.2.1/x86
patch-configure-fix-x86 (4.8 KB) - added by pguyot (Paul Guyot) 16 years ago.
Replacement for patch-configure that should fix the problem.
ocaml.log.2.txt (213.3 KB) - added by mww@… 16 years ago.
Logfile - now fails with linker error
patch-configure (5.1 KB) - added by pguyot (Paul Guyot) 16 years ago.
New patch-configure that would enable dynamic libraries on x86.
Makefile (1.5 KB) - added by mww@… 16 years ago.
config/Makefile
ocaml.log (213.6 KB) - added by mww@… 16 years ago.
Logile, build no 3.

Download all attachments as: .zip

Change History (12)

Changed 16 years ago by mww@…

Attachment: ocaml.log.txt added

Logfile of the build on OpenDarwin-7.2.1/x86

comment:1 Changed 16 years ago by pguyot (Paul Guyot)

Status: newassigned

OK Markus. Got it. However, on OD/x86, we might not have a native compiler (until I get access to some OD/x86 box).

I'm attaching a new patch-configure file. Replace the one in CVS by this one and let me know how it works. I'll also be interested in a full log to see if the native compiler is there, and if so, it would be good to do some tests by compiling various ocaml programs from DP.

BTW, this may also fix the sparc/openbsd issue.

Changed 16 years ago by pguyot (Paul Guyot)

Attachment: patch-configure-fix-x86 added

Replacement for patch-configure that should fix the problem.

Changed 16 years ago by mww@…

Attachment: ocaml.log.2.txt added

Logfile - now fails with linker error

comment:2 Changed 16 years ago by mww@…

attachments.isobsolete: 01

Changed 16 years ago by pguyot (Paul Guyot)

Attachment: patch-configure added

New patch-configure that would enable dynamic libraries on x86.

comment:3 Changed 16 years ago by pguyot (Paul Guyot)

attachments.isobsolete: 01

Changed 16 years ago by mww@…

Attachment: Makefile added

config/Makefile

Changed 16 years ago by mww@…

Attachment: ocaml.log added

Logile, build no 3.

comment:4 Changed 16 years ago by mww@…

attachments.isobsolete: 01

comment:5 Changed 16 years ago by snu@…

Summary: ocaml fails on OpenDarwin/x86BUG: ocaml fails on OpenDarwin/x86

Please use summary prefix.

comment:6 Changed 15 years ago by markd@…

Resolution: duplicate
Status: assignedclosed

* This bug has been marked as a duplicate of 7890 *

Note: See TracTickets for help on using tickets.