Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#24808 closed defect (fixed)

wrong portname used in mportdepends for path-based depspecs

Reported by: takanori@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.8.99
Keywords: Cc:
Port: pTeX tex-tipa

Description

# First of all, 'tex-tipa' is one of the TeX package, and 'pTeX' is a TeX distribution mainly used in Japan.

I tried to install tex-tipa after pTeX, but it failed due to the following error.

how to reproduce:

$ port version
Version: 1.8.99

$ port installed
No ports are installed.

$ sudo port install pTeX
...

$ sudo port install tex-tipa
--->  Computing dependencies for tex-tipaError: Unable to execute port: Can't install texlive because conflicting ports are installed: pTeX
To report a bug, see <http://guide.macports.org/#project.tickets>

This problem didn't occur with MacPorts 1.8.2.

Change History (4)

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Well, the texlive and pTeX ports do mark themselves as conflicting with one another. So it should not be a surprise that you can't install both at the same time. You should see the same error with MacPorts 1.8.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Component: baseports
Port: pTeX tex-tipa added
Summary: MacPorts 1.9.0-beta1: cannot install tex-tipa with pTeXtex-tipa conflicts with pTeX

So are you saying that the bin:mktexlsr:texlive dependency should be satisfied by pTeX, so texlive should not be installing? Need debug output please.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Component: portsbase
Resolution: fixed
Status: newclosed
Summary: tex-tipa conflicts with pTeXwrong portname used in mportdepends for path-based depspecs

comment:4 in reply to:  2 Changed 11 years ago by takanori@…

Replying to jmr@…:

So are you saying that the bin:mktexlsr:texlive dependency should be satisfied by pTeX, so texlive should not be installing?

Right. Because pTeX provides mktexlsr, 'depends_lib bin:mktexlsr:texlive' should be satisfied by pTeX, as well as texlive.

Replying to jmr@…:

Need debug output please.

$ port log tex-tipa
DEBUG: Found Dependency: path: /usr/bin filename: unzip regex: ^unzip$
DEBUG: Found Dependency: path: /opt/local/bin filename: mktexlsr regex: ^mktexlsr$
--->  Computing dependencies for tex-tipa:msg:main 
DEBUG: Searching for dependency: unzip
DEBUG: Didn't find receipt, going to depspec regex for: unzip
DEBUG: Found Dependency: path: /usr/bin filename: unzip regex: ^unzip$
DEBUG: Searching for dependency: texlive
DEBUG: Didn't find receipt, going to depspec regex for: texlive
DEBUG: Found Dependency: path: /opt/local/bin filename: mktexlsr regex: ^mktexlsr$
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/tex/texlive
DEBUG: OS darwin/10.3.0 (Mac OS X 10.6) arch i386
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: not using configure, so not adding the default universal variant
DEBUG: Checking for conflicts against texlive
DEBUG: Searching for dependency: pTeX
DEBUG: Found Dependency: receipt exists for pTeX
DEBUG: Can't install texlive because conflicting ports are installed: pTeX
Error: Unable to execute port: Can't install texlive because conflicting ports are installed: pTeX
To report a bug, see <http://guide.macports.org/#project.tickets>

I confirmed that this problem was fixed by r67384. Thanks.

Note: See TracTickets for help on using tickets.