Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#24862 closed defect (duplicate)

help2man: perl module Locale::gettext required

Reported by: dxjones@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: help2man

Description (last modified by ryandesign (Ryan Schmidt))

There is a problem related to "help2man".

All commands fail when trying to update "help2man", including:

# sudo port -d upgrade outdated

# sudo port -d install sox

Here is the debugging output:

--->  Configuring help2man
DEBUG: Using compiler 'Mac OS X gcc 4.2'
DEBUG: Executing org.macports.configure (help2man)
DEBUG: Environment: CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-O2 -arch x86_64' MACOSX_DEPLOYMENT_TARGET='10.6' PERL='/opt/local/bin/perl' CXX='/usr/bin/g++-4.2' F90FLAGS='-O2 -m64' LDFLAGS='-L/opt/local/lib' OBJC='/usr/bin/gcc-4.2' FCFLAGS='-O2 -m64' INSTALL='/usr/bin/install -c' OBJCFLAGS='-O2 -arch x86_64' FFLAGS='-O2 -m64' CC='/usr/bin/gcc-4.2'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && ./configure --prefix=/opt/local --enable-nls'
checking for perl... /opt/local/bin/perl
checking for module Locale::gettext... no
checking for msgfmt... /opt/local/bin/msgfmt
checking for gcc... /usr/bin/gcc-4.2
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.2 accepts -g... yes
checking for /usr/bin/gcc-4.2 option to accept ISO C89... none needed
checking for library containing dlsym... none required
checking for library containing bindtextdomain... -lintl
configure: error: perl module Locale::gettext required
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && ./configure --prefix=/opt/local --enable-nls " returned error 1
DEBUG: Backtrace: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.37.1" && ./configure --prefix=/opt/local --enable-nls " returned error 1
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for help2man): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Problem while installing help2man
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (5)

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; dxjones@… removed
Description: modified (diff)
Keywords: help2man removed
Milestone: MacPorts 1.9.0
Priority: HighNormal
Summary: help2man install failure (sudo port -d upgrade outdated) on Snow Leopardhelp2man: perl module Locale::gettext required

Please remember WikiFormatting, don't set the Milestone field for port tickets, don't set ticket priorities to High. Note that you don't need to Cc yourself.

It says it can't find Locale::gettext, but help2man does depend on the p5-locale-gettext port. Is it installed and active?

Did you recently upgrade to Snow Leopard? If so, did you read and follow the Migration procedure?

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Closing due to lack of further information.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: closedreopened

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually a dupe of #21069.

comment:5 Changed 10 years ago by cornelius.howl@…

omg,

I can't install too, I've remove all ports and reinstall them all but still FAIL!

Note: See TracTickets for help on using tickets.