Opened 11 years ago

Closed 11 years ago

#24974 closed defect (fixed)

libgtkhtml3 @3.26.3_2 fails to compile

Reported by: h_hettema@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: libgtkhtml3

Description

libraries on which libgtkhtml3 depends no longer support deprecated GTK_WIDGET_SENSITIVE and GTK_WIDGET_VISIBLE. Replacing these calls in the source (a11y/object.c) with gtk_widget_get_sensitive and gtk_widget_get_visible resulted in successful compilation.

Change History (3)

comment:1 Changed 11 years ago by lhorner@…

I confirm that this fix works.

MacBook running 10.6.3 Xcode 3.2.2 Macports 1.8.2

I've attempted to report upstream, but in doing so noticed that libgtkhtml3 is at 3.31 now so it's possible that using the latest would fix the problem. I haven't looked into what changed between the versions or tried using the newer version.

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

I didn't know whether this project uses the even-number-stable/odd-number-development release numbering strategy, so I updated the port to the newest even-numbered release, 3.30.1, in r68469.

Note: See TracTickets for help on using tickets.