Opened 10 years ago

Closed 10 years ago

#25012 closed defect (fixed)

fontforge @20090923: undefined symbol _libintl_setlocale

Reported by: gale@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: fontforge

Description

On Snow Leopard, installing (not upgrading)

/usr/bin/gcc-4.2 -dynamiclib  -o ../.libs/libfontforge.1.0.0.dylib  .libs/asmfpst.o .libs/autohint.o

<snip>

-L/opt/local/lib -L/usr/local/lib ../.libs/libgutils.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_fontforge/work/fontforge-20090923/.libs/libgunicode.dylib ../.libs/libgunicode.dylib /opt/local/lib/libiconv.dylib -lpthread -lm  -arch x86_64 -Wl,/System/Library/Frameworks/CoreServices.framework/CoreServices -Wl,/System/Library/Frameworks/Carbon.framework/Carbon -install_name  /opt/local/lib/libfontforge.1.dylib -compatibility_version 2 -current_version 2.0 -Wl,-single_module
Undefined symbols:
  "_libintl_setlocale", referenced from:
      __ExportPlate in cvexport.o
      __ExportPlate in cvexport.o
      __ExportPDF in cvexport.o
      __ExportPDF in cvexport.o
      __ExportEPS in cvexport.o
      __ExportEPS in cvexport.o
      __WritePSFont in dumppfa.o
      __WritePSFont in dumppfa.o
      __InterpretPdf in parsepdf.o

<snip>

Change History (6)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

This was just updated to 20100501; is there still a problem?

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Confirmed; fontforge doesn't build with gettext 0.18. Works fine with gettext 0.17, so if you need fontforge right now, you can downgrade gettext (with all the fun that entails). Upgrading fontforge to 20100501 (r67983) didn't help. I reported this problem to the fontforge-devel mailing list.

comment:3 Changed 10 years ago by gale@…

Perhaps the second part of this thread is relevant?

comment:4 Changed 10 years ago by jmroot (Joshua Root)

The symbol in question is present in the libintl installed by gettext 0.18. The problem seems to be that the link command here doesn't include -lintl.

comment:5 in reply to:  4 ; Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

Oops, didn't see your notes until now because I forgot to Cc myself on this ticket.

Replying to gale@…:

Perhaps the second part of this thread is relevant?

It doesn't seem to be.

Replying to jmr@…:

The symbol in question is present in the libintl installed by gettext 0.18. The problem seems to be that the link command here doesn't include -lintl.

That's also what George White found and wrote about on fontforge-devel. I agree adding -lintl to the ldflags works. I'm still unclear why this was working with gettext 0.17 but now isn't with 0.18.

comment:6 in reply to:  5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Replying to ryandesign@…:

I agree adding -lintl to the ldflags works.

Fixed in r68052.

Note: See TracTickets for help on using tickets.