Opened 10 years ago

Closed 10 years ago

#25028 closed defect (duplicate)

gcc42 -- build failure

Reported by: aeronova Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: gcc42

Description (last modified by ryandesign (Ryan Schmidt))

Please check this message.
(Mac OS X Snow Leopard 10.6.3)

--->  Building gcc42
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc42/work/build" && /usr/bin/make -j2 all " returned error 2
Command output: /usr/bin/ranlib: file: .libs/libgfortran.a(_exp_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_log_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_log_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_log10_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sqrt_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sqrt_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_asin_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_asinh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_acos_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_acosh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_atan_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_atanh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sin_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sin_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_cos_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_cos_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_tan_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sinh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_cosh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_tanh_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_conjg_c16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_aint_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_anint_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_sign_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_dim_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_atan2_r16.o) has no symbols
/usr/bin/ranlib: file: .libs/libgfortran.a(_mod_r16.o) has no symbols
creating libgfortran.la
(cd .libs && rm -f libgfortran.la && ln -s ../libgfortran.la libgfortran.la)
make: *** [all] Error 2

Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.
lawn-128-61-20-94:~ aeronova$ sudo port install -d gcc42
Password:
--->  Computing dependencies for gcc42
--->  Building gcc42
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc42/work/build" && /usr/bin/make -j2 all " returned error 2
Command output: 		if (cd ../${dir}/${lib}; /usr/bin/make "AR=/usr/bin/ar" "AR_FLAGS=rc" "CC=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc42/work/build/./gcc/xgcc -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc42/work/build/./gcc/ -B/opt/local/x86_64-apple-darwin10/bin/ -B/opt/local/x86_64-apple-darwin10/lib/ -isystem /opt/local/x86_64-apple-darwin10/include -isystem /opt/local/x86_64-apple-darwin10/sys-include" "CFLAGS=-O2 -O2 " "DESTDIR=" "LIBCFLAGS=-O2 -O2 " "EXTRA_OFILES=" "HDEFINES=" "INSTALL=/usr/bin/install -c" "INSTALL_DATA=/usr/bin/install -c -m 644" "INSTALL_PROGRAM=/usr/bin/install -c" "LDFLAGS=" "LIBTOOL=/bin/sh ./libtool" "LOADLIBES=" "PICFLAG=" "RANLIB=/usr/bin/ranlib -c" "SHELL=/bin/sh" "prefix=/opt/local" "exec_prefix=/opt/local" "libdir=/opt/local/lib/gcc42" "libsubdir=/opt/local/lib/gcc42/gcc/x86_64-apple-darwin10/4.2.4" "tooldir=/opt/local/x86_64-apple-darwin10" \
				CFLAGS="-O2 -O2  ${flags}" \
				CCASFLAGS=" ${flags}" \
				FCFLAGS=" ${flags}" \
				FFLAGS=" ${flags}" \
				ADAFLAGS=" ${flags}" \
				prefix="/opt/local" \
				exec_prefix="/opt/local" \
				GCJFLAGS=" ${flags}" \
				CXXFLAGS="-O2  ${flags}" \
				LIBCFLAGS="-O2 -O2  ${flags}" \
				LIBCXXFLAGS="-O2  -fno-implicit-templates ${flags}" \
				LDFLAGS=" ${flags}" \
				MULTIFLAGS="${flags}" \
				DESTDIR="" \
				INSTALL="/usr/bin/install -c" \
				INSTALL_DATA="/usr/bin/install -c -m 644" \
				INSTALL_PROGRAM="/usr/bin/install -c" \
				INSTALL_SCRIPT="/usr/bin/install -c" \
				all); then \
		  true; \
		else \
		  exit 1; \
		fi; \
	      else true; \
	      fi; \
	    fi; \
	  done; \
	fi
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Change History (2)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: gcc42 libgfortran.la removed
Owner: changed from macports-tickets@… to mww@…
Port: gcc42 added

Please remember to preview and use WikiFormatting, to fill in the Port field, and to Cc the port maintainer.

FYI, in order to have any effect, the '-d' flag must go immediately after the word 'port', e.g.

sudo port -d install gcc42

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

And finally, this is a duplicate of #21665.

Note: See TracTickets for help on using tickets.