Opened 10 years ago

Closed 10 years ago

#25029 closed defect (duplicate)

kdebase4-runtime: cannot allocate an object of abstract type 'Attica::KdePlatformDependent'

Reported by: ratonovitch@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: sharky@…
Port: kdebase4-runtime

Description

I started with a fresh install of macports 1.8.3, installed using the MacPorts-1.8.2.pkg installer. The first thing I did was

  % sudo port install kdebase4

This failed. Details are in the attached logfile (created using port -d).

System Version: Mac OS X 10.6.3 (10D573)
Kernel Version: Darwin 10.3.0

% uname -a
Darwin monaco 10.3.0 Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09 PST 2010; root:xnu-1504.3.12~1/RELEASE_I386 i386

Xcode Version 3.2.2 (1650)

Please let me know if you need further information.

Attachments (1)

kdebase4.build.log (699.5 KB) - added by ratonovitch@… 10 years ago.
output of 'port -d install kdebase4'

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by ratonovitch@…

Attachment: kdebase4.build.log added

output of 'port -d install kdebase4'

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: sharky@… added
Owner: changed from macports-tickets@… to snc@…
Port: kdebase4-runtime added
Summary: kdebase4 4.4.3_1 attica dependency - build failurekdebase4-runtime: cannot allocate an object of abstract type 'Attica::KdePlatformDependent'

Please remember to indicate the actual port that failed, fill in the port field, and Cc the maintainers.

The relevant error seems to be:

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp: In function 'QObject* qt_plugin_instance()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:225: error: cannot allocate an object of abstract type 'Attica::KdePlatformDependent'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.h:42: note:   because the following virtual functions are pure within 'Attica::KdePlatformDependent':
/opt/local/include/attica/platformdependent.h:47: note: 	virtual void Attica::PlatformDependent::addDefaultProviderFile(const QUrl&)
/opt/local/include/attica/platformdependent.h:48: note: 	virtual void Attica::PlatformDependent::removeDefaultProviderFile(const QUrl&)
/opt/local/include/attica/platformdependent.h:53: note: 	virtual void Attica::PlatformDependent::enableProvider(const QUrl&, bool) const
/opt/local/include/attica/platformdependent.h:54: note: 	virtual bool Attica::PlatformDependent::isEnabled(const QUrl&) const
make[2]: *** [attica/kdeplugin/CMakeFiles/attica_kde.dir/kdeplatformdependent.o] Error 1
make[1]: *** [attica/kdeplugin/CMakeFiles/attica_kde.dir/all] Error 2

There are a few reports of this error on Google; maybe one of those has a solution.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Also, this is a duplicate of #24947.

comment:3 in reply to:  2 ; Changed 10 years ago by (none)

Resolution: duplicate
Status: closedreopened

Replying to ryandesign@…:

Also, this is a duplicate of #24947.

Sorry to be the barer of bad news but this isn't fixed by the fix for 25947.

brand new ports database. ---> Building kdebase4-runtime Error: Target org.macports.build returned: shell command failed Log for kdebase4-runtime is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/main.log Error: The following dependencies failed to build: kdebase4-runtime mlt doxygen coreutils graphviz gd2 xpm urw-fonts xorg-libXaw groff xorg-libXmu ffmpeg-devel XviD dirac cppunit faac faad2 lame libogg libsdl libtheora libvorbis schroedinger orc liboil x264 frei0r-plugins gavl git-core p5-error rsync popt opencv ffmpeg libdv libsamplerate libsndfile flac sox file libao libid3tag libmad wavpack Error: Status 1 encountered during processing. To report a bug, see <http://guide.macports.org/#project.tickets>

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp: In function 'QObject* qt_plugin_instance()': :info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.cpp:225: error: cannot allocate an object of abstract type 'Attica::KdePlatformDependent' :info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/work/kdebase-runtime-4.4.3/attica/kdeplugin/kdeplatformdependent.h:42: note: because the following virtual functions are pure within 'Attica::KdePlatformDependent': :info:build /opt/local/include/attica/platformdependent.h:47: note: virtual void Attica::PlatformDependent::addDefaultProviderFile(const QUrl&) :info:build /opt/local/include/attica/platformdependent.h:48: note: virtual void Attica::PlatformDependent::removeDefaultProviderFile(const QUrl&) :info:build /opt/local/include/attica/platformdependent.h:53: note: virtual void Attica::PlatformDependent::enableProvider(const QUrl&, bool) const :info:build /opt/local/include/attica/platformdependent.h:54: note: virtual bool Attica::PlatformDependent::isEnabled(const QUrl&) const :info:build make[2]: * [attica/kdeplugin/CMakeFiles/attica_kde.dir/kdeplatformdependent.o] Error 1 :info:build make[1]: * [attica/kdeplugin/CMakeFiles/attica_kde.dir/all] Error 2 :info:build make: * [all] Error 2

I appear to have the patch for the other bug already installed.

comment:4 in reply to:  3 Changed 10 years ago by (none)

Replying to julian@…:

I appear to have the patch for the other bug already installed.

adding more info: OS-X 10.5.8 not a lot of stuff installed. mac-ports was previously only used to install wireshark and ImageMagik before trying to install kdenlive.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: duplicate
Status: reopenedclosed

This is still a duplicate of #24947.

Note: See TracTickets for help on using tickets.