Opened 10 years ago

Closed 10 years ago

#25133 closed defect (fixed)

latexit needs pdftex at runtime

Reported by: anddam (Andrea D'Amore) Owned by: singingwolfboy@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: latexit

Description

LaTeXiT port needs pdftex to run properly, installing it without any tex installation ends up in a non working program, not what end users expect.

I suggest to add a

depends_run texlive

Since texlive install a lot of ports you may want to add a variant to explicitly disable texlive dependency and rely on an external provided pdftex.

Change History (1)

comment:1 Changed 10 years ago by singingwolfboy@…

Resolution: fixed
Status: newclosed

Thanks for catching that! Committed in r68483. I used "mactex" as the name of the variant, following the auxtex port's example.

Note: See TracTickets for help on using tickets.