Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#25134 closed defect (worksforme)

libsndfile bad #include

Reported by: anddam (Andrea D'Amore) Owned by: lperry (Perry Lee)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: include carbon Cc:
Port: libsndfile

Description

I've been suggested that programs/sndfile-play.c in worksrcdir has a wrong include for "Carbon.h".

This Apple document suggests that the include should be

#include <Carbon/Carbon.h>

I'm not able to reproduce the broken build myself but I'm attaching a patch.

Attachments (1)

patch-libsndfile.diff (974 bytes) - added by anddam (Andrea D'Amore) 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by anddam (Andrea D'Amore)

Attachment: patch-libsndfile.diff added

comment:1 Changed 11 years ago by tobypeterson

Carbon.h should be fine, unless /Developer/Headers/FlatCarbon is missing for some reason?

comment:2 Changed 11 years ago by anddam (Andrea D'Amore)

True, his XCode wasn't installed in /Developer but the path should have been grepped by xcode-select -print-path in portmain::get_developer_dir, shouldn't it?

Is this a MacPorts or system behaviour?

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Builds fine for me as is.

comment:4 Changed 11 years ago by lperry (Perry Lee)

Resolution: worksforme
Status: newclosed

I'm resolving this as worksforme since it appears to build fine for all of us. Also the referenced Apple document states:

For Carbon developers porting their source code from Mac OS 9 to Mac OS X, including only the Carbon.h header file may require changes to many source files that might be difficult to make right away. For this situation, Apple provides a “flat header” alternative that lets you continue to use your present #include commands.

comment:5 Changed 10 years ago by holms@…

New Xcode directory is called /Xcode64 from nowon.. So i had error with carbon too... developers must detect xcode folder, and not hardcore xcode folder =(

Note: See TracTickets for help on using tickets.