Opened 10 years ago

Closed 6 years ago

#25192 closed defect (worksforme)

Trying to install p5-pdl but get error from Karma

Reported by: caa@… Owned by: te.pickering@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: p5-pdl

Description

I get an error when doing:

sudo port install p5-pdl

See attached file.

Mac OSX 10.6.3, Mac Pro.

Thanks.

Attachments (1)

zzz (17.0 KB) - added by caa@… 10 years ago.
Output from sudo port -d install p5-pdl

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by caa@…

Attachment: zzz added

Output from sudo port -d install p5-pdl

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to te.pickering@…

Please remember to cc the maintainer.

comment:2 in reply to:  1 ; Changed 10 years ago by tim@…

Replying to jmr@…:

Please remember to cc the maintainer.

looks like i need to patch the perldl.conf file to explicitly turn off karma support. it defaults to 'undef' so it'll look for karma at config time and it's probably finding yours, but not configuring itself correctly for where it's installed.

karma is not included in macports and i'm not interested in supporting it. if someone submits it and it gets accepted, then i can modify p5-pdl to support it.

comment:3 in reply to:  2 Changed 10 years ago by caa@…

Replying to tim@…:

Replying to jmr@…:

Please remember to cc the maintainer.

looks like i need to patch the perldl.conf file to explicitly turn off karma support. it defaults to 'undef' so it'll look for karma at config time and it's probably finding yours, but not configuring itself correctly for where it's installed.

karma is not included in macports and i'm not interested in supporting it. if someone submits it and it gets accepted, then i can modify p5-pdl to support it.

I don't need Karma, can I modify the perldl.conf myself to get pdl built??

comment:4 Changed 6 years ago by mf2k (Frank Schima)

Keywords: perl data language removed
Resolution: worksforme
Status: newclosed

This problem seems obsolete. Please re-open this ticket if this is happening with version 2.7.0.

Note: See TracTickets for help on using tickets.