Opened 11 years ago

Closed 11 years ago

#25206 closed enhancement (duplicate)

py{25,26}-numpy should use gcc44

Reported by: shawn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: haspatch, numpy, python Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez), skymoo (Adam Mercer)
Port: py26-numpy

Description

py25-numpy and py26-numpy both have atlas as their dependencies. Atlas now depends on gcc44 by default, and py{25,26}-numpy should probably also to avoid requiring both gcc43 and gcc44.

Attached are patch files for both ports.

Attachments (2)

Portfile_py25-numpy.patch (1.9 KB) - added by shawn@… 11 years ago.
Patch for py25-numpy portfile (change from gcc43 to gcc44)
Portfile_py26-numpy.patch (2.0 KB) - added by shawn@… 11 years ago.
Patch for py26-numpy portfile (change from gcc43 to gcc44)

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by shawn@…

Attachment: Portfile_py25-numpy.patch added

Patch for py25-numpy portfile (change from gcc43 to gcc44)

Changed 11 years ago by shawn@…

Attachment: Portfile_py26-numpy.patch added

Patch for py26-numpy portfile (change from gcc43 to gcc44)

comment:1 Changed 11 years ago by skymoo (Adam Mercer)

also see #19397, which has a fix for universal builds

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Type: updateenhancement

This could be considered a dupe of #20103 (or #25081). Everything should be using the same default, and atlas is the one that's currently out of line.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.