Opened 10 years ago

Closed 10 years ago

#25244 closed defect (invalid)

py26-matplotlib: You must install numpy 1.1 or later to build

Reported by: info@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc:
Port: py26-matplotlib

Description

I'm running the command: sudo port -d install py26-nltk

And it's failing to build with py26-matplotlib and py26-yaml left as dependencies. Debug log is attached. Thanks for any insights!

Attachments (1)

py26-nltk.output (83.2 KB) - added by info@… 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by info@…

Attachment: py26-nltk.output added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: matplotlib nltk removed
Owner: changed from macports-tickets@… to ram@…
Port: py26-matplotlib added
Summary: matplotlib: 0.99.3 build failure on Mac OS 10.6.3 during py26-nltk installpy26-matplotlib: You must install numpy 1.1 or later to build

The relevant error in your log appears to be "You must install numpy 1.1 or later to build". py26-numpy is declared as a dependency of py26-matplotlib. Is py26-numpy installed and active?

comment:2 in reply to:  1 ; Changed 10 years ago by info@…

Replying to ryandesign@…:

The relevant error in your log appears to be "You must install numpy 1.1 or later to build". py26-numpy is declared as a dependency of py26-matplotlib. Is py26-numpy installed and active?

I assumed it was installed and active because I ran the whole thing, and it only listed py26-matplotlib and py26-yaml as remaining dependencies. What's the best way to check?

I saw that the MacPorts process also installed another version of python, and there was a message about switching to use that version - is that the one that I need to use? Should I also not have a PYTHONPATH set, would that mess up the install?

comment:3 Changed 10 years ago by info@…

DEBUG: py26-numpy 1.4.1_1 exists in the ports tree DEBUG: py26-numpy 1.4.1_1 is the latest installed DEBUG: py26-numpy 1.4.1_1 is active

comment:4 in reply to:  2 ; Changed 10 years ago by skymoo (Adam Mercer)

Status: newassigned

Replying to info@…:

I saw that the MacPorts process also installed another version of python, and there was a message about switching to use that version - is that the one that I need to use?

What do you mean by "need to use"? The python_select script just creates a python symlink pointing to the specified python version. Whether you run that command or not should have no effect on matplotlib being able to find NumPy. I would guess that theres some problem with your NumPy installation.

Should I also not have a PYTHONPATH set, would that mess up the install?

The modules are installed in the default location for where python is installed so you do not need to set PYTHONPATH.

During the build of matplotlib it simply tries to import the numpy module, if that fails it returns the error message to you quote above. Does the following command return any output:

$ /opt/local/bin/python2.6 -c "import numpy"
$

Assuming you're prefix is /opt/local, the command should run for a while and then return to the prompt.

comment:5 in reply to:  4 Changed 10 years ago by skymoo (Adam Mercer)

Replying to ram@…:

Assuming you're prefix is /opt/local...

Damn, should proof read after changing wording :-(

comment:6 in reply to:  4 Changed 10 years ago by info@…

Replying to ram@…:

What do you mean by "need to use"? The python_select script just creates a python symlink pointing to the specified python version. Whether you run that command or not should have no effect on matplotlib being able to find NumPy. I would guess that theres some problem with your NumPy installation.

$ /opt/local/bin/python2.6 -c "import numpy"

Traceback (most recent call last):

File "<string>", line 1, in <module> File "/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/init.py", line 132, in <module>

import add_newdocs

File "/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/add_newdocs.py", line 9, in <module>

from lib import add_newdoc

File "/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/lib/init.py", line 4, in <module>

from type_check import *

File "/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/lib/type_check.py", line 8, in <module>

import numpy.core.numeric as _nx

File "/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/core/init.py", line 5, in <module>

import multiarray

ImportError: dlopen(/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/core/multiarray.so, 2): no suitable image found. Did find:

/Users/xxxx/Library/Python/2.6/site-packages/numpy-1.4.1-py2.6-macosx-10.3-fat.egg/numpy/core/multiarray.so: no matching architecture in universal wrapper

comment:7 Changed 10 years ago by skymoo (Adam Mercer)

You've installed another NumPy, a 32bit version, into your home directory so this is getting picked up. Remove this and you should be good. As another option you can place the MacPorts location in the PYTHONPATH ahead of this version, but I would advise simply removing this home directory installation as it's going to cause further problems down the line.

comment:8 Changed 10 years ago by info@…

That did it! Thanks for the translation of the error messages! :)

comment:9 Changed 10 years ago by skymoo (Adam Mercer)

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.