Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#25272 closed defect (duplicate)

Etoile-0.1.9: PopplerKit failed to build

Reported by: trog24 (Frank J. R. Hanstick) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc:
Port: Etoile

Description

When trying to install gnustep, the following error occurred during the PopplerKit build:

Build Project: PopplerKit

Making build-headers in subprojects of framework PopplerKit...
Making build-headers for subproject bindings...
gnumake[4]: Nothing to be done for `internal-subproject-build-headers'.
Making build-headers for subproject MissingKit...
gnumake[4]: Nothing to be done for `internal-subproject-build-headers'.
Making build-headers for framework PopplerKit...
cd ./PopplerKit.framework; \
	  if [ ! -h "Resources" ]; then \
	    rm -f Resources; \
	    ln -s Versions/Current/Resources Resources; \
	  fi; \
	  if [ ! -h "Headers" ]; then \
	    rm -f Headers; \
	    ln -s Versions/Current/Headers Headers; \
	  fi
cd ./derived_src; \
	  if [ ! -h "PopplerKit" ]; then \
	    rm -f ./PopplerKit; \
	    ln -s ../PopplerKit.framework/Headers \
                    ./PopplerKit; \
	  fi
Making all in subprojects of framework PopplerKit...
Making all for subproject bindings...
/usr/bin/gnumake -f GNUmakefile --no-print-directory --no-keep-going \
	internal-subproject-compile \
	GNUSTEP_TYPE=subproject \
	GNUSTEP_INSTANCE=bindings \
	GNUSTEP_OPERATION=compile \
	GNUSTEP_BUILD_DIR="." \
	_GNUSTEP_MAKE_PARALLEL=yes
gnumake[5]: *** No rule to make target `obj/poppler.c.o', needed by `obj/subproject.o'.  Stop.
gnumake[4]: *** [internal-subproject-all_] Error 2
gnumake[3]: *** [bindings.all.subproject.variables] Error 2
gnumake[2]: *** [PopplerKit.all.framework.variables] Error 2
gnumake[1]: *** [internal-all] Error 2
gnumake: *** [internal-all] Error 2
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnustep_Etoile/work/Etoile" && /usr/bin/gnumake -j2 all messages=yes GNUSTEP_MAKEFILES=/opt/local/GNUstep/System/Library/Makefiles azalea=no background=no dock=no login=no corner=no idle=no azswitch=no jabber=no outerspace=no sketch=no " returned error 2
Error: Target org.macports.build returned: shell command failed
DEBUG: Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for Etoile): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Log for Etoile is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnustep_Etoile/main.log
Error: The following dependencies failed to build: GNUMail Etoile Pantomime PRICE TalkSoup netclasses Yap.app a2ps psutils gworkspace system-preferences PreferencePanes windowmaker
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The platform is an upgraded PowerPC Quicksilver running MacOS 10.5.8.

Change History (3)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Port: Etoile added; etoile removed
Summary: PopplerKit failed to buildEtoile-0.1.9: PopplerKit failed to build

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

I'll call this a duplicate of #20776.

comment:3 Changed 10 years ago by trog24 (Frank J. R. Hanstick)

The problem is downloading an outdated version?

Note: See TracTickets for help on using tickets.