Opened 10 years ago

Closed 10 years ago

#25275 closed defect (duplicate)

arpack build error : shel commande failed

Reported by: antoine.tiberj@… Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc:
Port: gcc43

Description (last modified by mf2k (Frank Schima))

System : macbook pro 2.8 GHz Intel Core 2 Duo, OS X 10.5.8, macports 1.90, Xcode 3.1.2, i686-apple-darwin9-gcc-4.0.1

Tiberj:10611 Tonio$ sudo port upgrade outdated
--->  Computing dependencies for arpack
--->  Building arpack
Error: Target org.macports.build returned: shell command failed
Log for arpack is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_arpack/main.log
Error: Unable to upgrade port: 1

please find attached the main. log file

Antoine

Attachments (1)

main.log (4.2 KB) - added by antoine.tiberj@… 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by antoine.tiberj@…

Attachment: main.log added

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to mmoll@…
Port: arpack added

comment:2 Changed 10 years ago by mamoll (Mark Moll)

Resolution: invalid
Status: newclosed

The error is in gfortran. Look at this part of main.log:

:info:build /opt/local/bin/gfortran-mp-4.3 -O2 -m32 -c svout.f
22	:info:build dyld: Library not loaded: /opt/local/lib/libmpfr.1.dylib
23	:info:build   Referenced from: /opt/local/libexec/gcc/i386-apple-darwin9/4.3.5/f951
24	:info:build   Reason: image not found
25	:info:build gfortran-mp-4.3: Internal error: Trace/BPT trap (program f951)

You may have upgraded to the new mpfr, which (I think) is not compatible with gcc43. I'd reinstall gcc43 and file a bug against gcc43 if doesn't produce a working gfortran compiler.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Port: gcc43 added; arpack removed
Resolution: invalid
Status: closedreopened

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually a duplicate of #25258.

Note: See TracTickets for help on using tickets.