Opened 11 years ago

Closed 10 years ago

#25313 closed defect (fixed)

DSDP-5.8 does not support build_arch

Reported by: dustin.314@… Owned by: mnick@…
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc: nerdling (Jeremy Lavergne), ryandesign (Ryan Schmidt)
Port: DSDP

Description

Build fails for DSDP 5.8. Using OS 10.6.3, Xcode 3.2.2.

Log excerpt:

:info:build i686-apple-darwin10-gcc-4.0.1: maxcut.o: No such file or directory
:info:build make[3]: *** [maxcut] Error 1
:info:build make[2]: *** [most] Error 2
:info:build make[1]: *** [example] Error 2
:info:build make: *** [dsdpapi] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_DSDP/work/DSDP5.8" && /usr/bin/make -j2 dsdpapi " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for DSDP): org.macports.activate org.macports.build org.macports.destroot org.macports.install

Change History (9)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Keywords: snowleopard added; Snow Leopard removed
Owner: changed from macports-tickets@… to mnick@…
Port: 5.8 removed

Please remember to cc the maintainer.

comment:2 Changed 11 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

This looks like a parallel build issue. Can you try the following and let us know how it goes?

sudo port clean DSDP
sudo port install DSDP build.jobs=1

comment:3 in reply to:  2 Changed 11 years ago by dustin.314@…

Replying to snc@…:

This looks like a parallel build issue. Can you try the following and let us know how it goes?

sudo port clean DSDP
sudo port install DSDP build.jobs=1

Tried cleaning and reinstalling as described above, but the build failed with another error. Thanks again for your help.

Log excerpt:

:info:build ld: warning: in /opt/local/lib/liblapack.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
:info:build Undefined symbols:
:info:build   "_dstevr_", referenced from:
:info:build       _DSDPGetTriDiagonalEigs in libdsdp.a(dsdpstep.o)
:info:build       _ComputeStepFAST in libdsdp.a(dsdpstep.o)
:info:build   "_dsyevr_", referenced from:
:info:build       _DSDPGetEigs in libdsdp.a(dufull.o)
:info:build   "_dsyevx_", referenced from:
:info:build       _DTRUMatEigs in libdsdp.a(dufull.o)
:info:build   "_dspevx_", referenced from:
:info:build       _DTPUMatEigs in libdsdp.a(dlpack.o)
:info:build   "_dpptrf_", referenced from:
:info:build       _DTPUMatCholeskyFactor in libdsdp.a(dlpack.o)
:info:build   "_dpptri_", referenced from:
:info:build       _DTPUMatInvert in libdsdp.a(dlpack.o)
:info:build       _DTPUMatInvert in libdsdp.a(dlpack.o)
:info:build   "_dpptrs_", referenced from:
:info:build       _DTPUMatSolve in libdsdp.a(dlpack.o)
:info:build   "_dstev_", referenced from:
:info:build       _DSDPGetTriDiagonalEigs in libdsdp.a(dsdpstep.o)
:info:build       _ComputeStepFAST in libdsdp.a(dsdpstep.o)
:info:build   "_dsyev_", referenced from:
:info:build       _DSDPGetEigs in libdsdp.a(dufull.o)
:info:build       _DvecumatFactor in libdsdp.a(dufull.o)
:info:build       _DSDPGetEigs2 in libdsdp.a(dufull.o)
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status
:info:build make[3]: *** [maxcut] Error 1
:info:build make[2]: *** [most] Error 2
:info:build make[1]: *** [example] Error 2
:info:build make: *** [dsdpapi] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_DSDP/work/DSDP5.8" && /usr/bin/make dsdpapi " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for DSDP): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for DSDP is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_DSDP/main.log

comment:4 Changed 11 years ago by nerdling (Jeremy Lavergne)

Looks like it has a unknown dependency on liblapack.dylib. I'm not familiar with the port has that file. What does this show:

port provides /opt/local/lib/liblapack.dylib

comment:5 in reply to:  4 Changed 11 years ago by dustin.314@…

Replying to snc@…:

Looks like it has a unknown dependency on liblapack.dylib. I'm not familiar with the port has that file. What does this show:

port provides /opt/local/lib/liblapack.dylib

output:

/opt/local/lib/liblapack.dylib is provided by: atlas

comment:6 Changed 11 years ago by nerdling (Jeremy Lavergne)

That's strange. For me, atlas builds that file x86_64 and for you it's i386, right? We can double check by running file /opt/local/lib/liblapack.dylib

comment:7 in reply to:  6 Changed 11 years ago by dustin.314@…

Replying to snc@…:

That's strange. For me, atlas builds that file x86_64 and for you it's i386, right? We can double check by running file /opt/local/lib/liblapack.dylib

Looks like it builds x86_64 for me as well:

/opt/local/lib/liblapack.dylib: Mach-O 64-bit dynamically linked shared library x86_64

Not sure what to make of that.

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

I tried over a dozen times and am unable to reproduce any parallel build failure.

Since DSDP clearly does use atlas, I added a dependency on it in r75968.

@dustin.314: you are on Snow Leopard... is your computer 64-bit capable, and if so, have you set your build_arch to i386 in macports.conf to request 32-bit builds instead of 64-bit builds? If so, that could explain the problem, since DSDP does not appear to respect build_arch and will try to build for the native architecture no matter what.

comment:9 Changed 10 years ago by jmroot (Joshua Root)

Keywords: snowleopard removed
Resolution: fixed
Status: newclosed
Summary: DSDP-5.8 Build failureDSDP-5.8 does not support build_arch

Assuming that was the problem, it should be fixed by r79608.

Note: See TracTickets for help on using tickets.