Opened 10 years ago

Closed 10 years ago

#25367 closed defect (fixed)

docbook-xml using wrong dependency type

Reported by: jpbn@… Owned by: boeyms@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: nerdling (Jeremy Lavergne)
Port: docbook-xml

Description (last modified by nerdling (Jeremy Lavergne))

It seems that when install gtk-doc, if docbook-xml or docbook-xsl are already installed via archives or if port_cutleaves has been called, gtk-doc will the not be able to find all necessary elements. This is likely due to docbook-xml/xsl only specifying their dependencies as depends_build and not depends_lib.

Attachments (1)

log (53.2 KB) - added by eoffermann@… 10 years ago.
Complete contents of log while installing gtk-doc

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…
Port: gtk-doc added
Summary: upgrading macportsgtk-doc configure failure

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer.

It's impossible to tell what the problem is from the few lines of output you have provided; please attach the log.

Changed 10 years ago by eoffermann@…

Attachment: log added

Complete contents of log while installing gtk-doc

comment:2 Changed 10 years ago by eoffermann@…

I was having the same problem: The relevant offending bit from the log is here:

:info:configure checking for DocBook XML DTD V4.3 in XML catalog... not found
:info:configure configure: error: could not find DocBook XML DTD V4.3 in XML catalog
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gtk-doc/work/gtk-doc-1.15" && ./configure --prefix=/opt/local --with-xml-catalog=/opt/local/etc/xml/catalog " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed
:debug:configure Backtrace: configure failure: shell command failed

comment:3 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

It seems that the dependency tree isn't being calculated correctly. Can you try the following:

sudo port uninstall docbook-xml docbook-xsl
sudo port install docbook-xml docbook-xsl
sudo port install gtk-doc

comment:4 Changed 10 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: newclosed

I can't reproduce this problem, no response for 4 months, assume resolved.

comment:5 Changed 10 years ago by pete@…

The fix mentioned by by snc works for me.

comment:6 Changed 10 years ago by nerdling (Jeremy Lavergne)

Description: modified (diff)
Port: docbook-xsl docbook-xml added; gtk-doc removed
Resolution: worksforme
Status: closedreopened
Summary: gtk-doc configure failuredocbook-xml/xsl missing dependencies

comment:7 Changed 10 years ago by nerdling (Jeremy Lavergne)

Owner: changed from devans@… to boeyms@…
Status: reopenednew

comment:8 Changed 10 years ago by jmroot (Joshua Root)

Port: docbook-xsl removed
Resolution: fixed
Status: newclosed
Summary: docbook-xml/xsl missing dependenciesdocbook-xml using wrong dependency type

This was fixed by r69380.

Note: See TracTickets for help on using tickets.