Opened 11 years ago

Closed 10 years ago

#25759 closed defect (fixed)

macfuse fails to build user-space library due to libtool problems

Reported by: george@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: macfuse

Description

 geo@lisa:/Users/geo/vcs sudo port install macfuse
Password:
--->  Computing dependencies for macfuse
--->  Cleaning macfuse
 geo@lisa:/Users/geo/vcs sudo port install sshfs-gui
--->  Computing dependencies for sshfs-gui
--->  Dependencies to be installed: sshfs
--->  Configuring sshfs
Error: Target org.macports.configure returned: configure failure: shell command failed
Log for sshfs is at: /usr/local/MacPorts/var/macports/logs/_usr_local_MacPorts_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs/main.log
Error: The following dependencies failed to build: sshfs
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
[1]    56687 exit 1     sudo port install sshfs-gui
 geo@lisa:/Users/geo/vcs tail -n19 /usr/local/MacPorts/var/macports/logs/_usr_local_MacPorts_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs/main.log
:info:configure checking pkg-config is at least version 0.9.0... yes
:info:configure checking for SSHFS... configure: error: Package requirements (fuse >= 2.2 glib-2.0 gthread-2.0) were not met:
:info:configure 
:info:configure No package 'fuse' found
:info:configure 
:info:configure Consider adjusting the PKG_CONFIG_PATH environment variable if you
:info:configure installed software in a non-standard prefix.
:info:configure 
:info:configure Alternatively, you may set the environment variables SSHFS_CFLAGS
:info:configure and SSHFS_LIBS to avoid the need to call pkg-config.
:info:configure See the pkg-config man page for more details.
:info:configure 
:info:configure shell command " cd "/usr/local/MacPorts/var/macports/build/_usr_local_MacPorts_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs/work/sshfs-fuse-2.2" && ./configure --prefix=/usr/local/MacPorts --disable-dependency-tracking " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed
:debug:configure Backtrace: configure failure: shell command failed
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for sshfs): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for sshfs is at: /usr/local/MacPorts/var/macports/logs/_usr_local_MacPorts_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs/main.log
 geo@lisa:/Users/geo/vcs port outdated
No installed ports are outdated.
 geo@lisa:/Users/geo/vcs port version
Version: 1.9.1

Attachments (3)

macfuse-debug-install-out+err-20100726-125549.txt (243.7 KB) - added by george@… 11 years ago.
macfuse_verbose_install_1.txt (90.7 KB) - added by someuser12 10 years ago.
Log of the first installation: "silently" failed
macfuse_verbose_install_2.txt (188.6 KB) - added by someuser12 10 years ago.
Log of the second installation: succeeded

Download all attachments as: .zip

Change History (19)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Cc: george@… removed
Keywords: sshfs fuse macfuse removed
Milestone: MacPorts 2.0.0

As per the ticket guidelines linked from the New Ticket page, please don't set the Milestone field.

comment:2 Changed 11 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:3 Changed 11 years ago by drkp (Dan Ports)

Owner: changed from macports-tickets@… to dports@…
Status: newassigned

Are you missing /opt/local/lib/pkgconfig/fuse.pc?

What version of macfuse do you have installed, and what does port contents macfuse show?

comment:4 Changed 11 years ago by drkp (Dan Ports)

Cc: dports@… removed

comment:5 Changed 11 years ago by george@…

I do not have a /opt/local/lib/pkgconfig/fuse.pc but that would be expected because my prefix is /usr/local/MacPorts/ however I do not have a /usr/local/MacPorts/lib/pkgconfig/fuse.pc either

I have macfuse @2.0.3, Revision 2 (fuse, devel) installed

Port macfuse contains:

/Library/Filesystems/fusefs.fs/Contents/Info.plist /Library/Filesystems/fusefs.fs/Contents/Resources/English.lproj/InfoPlist.strings /Library/Filesystems/fusefs.fs/Contents/version.plist /Library/Filesystems/fusefs.fs/Support/autoinstall-macfuse-core /Library/Filesystems/fusefs.fs/Support/fusefs.kext/Contents/Info.plist /Library/Filesystems/fusefs.fs/Support/fusefs.kext/Contents/MacOS/fusefs /Library/Filesystems/fusefs.fs/Support/load_fusefs /Library/Filesystems/fusefs.fs/Support/mount_fusefs /Library/Filesystems/fusefs.fs/Support/uninstall-macfuse-core.sh

note, MacPorts was installed on this new system about a month ago, perhaps fuse.pc is only produced on an older MacPorts version?

comment:6 Changed 11 years ago by drkp (Dan Ports)

Is that the full list of contents for macfuse? It's missing all the headers and libraries in $prefix/lib and $prefix/include.

Perhaps the port does not work with non-standard prefixes? (This would be a bug. I can't think of any reason it wouldn't...)

Can you uninstall macfuse and upload the output of port -d install macfuse?

Changed 11 years ago by george@…

comment:7 Changed 11 years ago by george@…

yes that was the complete 'port contents macfuse' output.

perhaps there was an attempt to install the headers & libraries in /opt/local/ with failure (but no stop) because that dir doesn't exist?

In 6 years of using macports in an alternate $PREFIX, I've had one other package fail because of it, TexShop I believe, and it was fixed.

uninstalled macfuse and ran port -d install macfuse 2>&1 see attached file: macfuse-debug-install-out+err-20100726-125549.txt

comment:8 Changed 11 years ago by george@…

note from attachment lines: 456 setenv USER_APPS_DIR /Users/geo/Applications 457 setenv USER_LIBRARY_DIR /Users/geo/Library

is that correct??? the command was run in the geo account as: sudo port -d install macfuse 2>&1

geo@lisa:/Users/geo find ~/Library -name \*fuse\* geo@lisa:/Users/geo find ~/Library ~/Applications -iname \*macfuse\*

find: /Users/geo/Applications: No such file or directory [1] 19744 exit 1 find ~/Library ~/Applications -iname \*macfuse\*

comment:9 Changed 11 years ago by george@…

 geo@lisa:/Users/geo find ~/Library -name \*fuse\*
 geo@lisa:/Users/geo find ~/Library ~/Applications -iname \*macfuse\*
find: /Users/geo/Applications: No such file or directory
[1]    19744 exit 1     find ~/Library ~/Applications -iname \*macfuse\*

comment:10 Changed 11 years ago by george@…

It is fixed, I don't know how. I do have port sync in daily cron, after above reinstalls I see there is a /usr/local/MacPorts/lib/pkgconfig/fuse.pc and the port contents macfuse is much more extensive. Also sshfs-gui installed without error, and it works!!

Issue closed!

Thank you!

-George

comment:11 Changed 11 years ago by drkp (Dan Ports)

Resolution: invalid
Status: assignedclosed

Well, no complaints from me when a problem goes away on its own!

Perhaps there's a missing dependency required to build macfuse that you didn't have installed the first time. I'll try it on a clean tree sometime soon.

comment:12 Changed 10 years ago by drkp (Dan Ports)

Someone else reported the same problem on IRC recently.

I tried installing macfuse on a clean installation of MacPorts (nothing installed) and wasn't able to reproduce this. So much for that idea.

comment:13 in reply to:  12 ; Changed 10 years ago by someuser12

Although my $prefix is the standard /opt/local, I had the problem too. The first time I ran port -vu install macfuse (actually, I ran port -vu install sshfs which triggered the installation of macfuse), it finished the installation but then sshfs failed to install, claiming that fuse was not installed. The contents of the macfuse port were the same as above (no headers and libraries in $prefix/include and $prefix/lib and no fuse.pc file).

Then I uninstalled macfuse (port uninstall macfuse) and reinstalled it straight away (without any port sync in between) and the second time the installation was complete.

Since I had run port in a screen session, I could look into the output of the first port install command and I noticed that there were lots of error messages like ../libtool: line 816: X--tag=CC: command not found. At the end this prevented the compilation of the library, but port kept going with staging into destroot and installed the parts of the package that go into /Liibrary/Filesystems.

I attach the outputs of the two runs of port -vu install macfuse: the first one which "silently" failed and the second one which succeeded. HTH.

Changed 10 years ago by someuser12

Log of the first installation: "silently" failed

Changed 10 years ago by someuser12

Log of the second installation: succeeded

comment:14 in reply to:  13 Changed 10 years ago by drkp (Dan Ports)

Resolution: invalid
Status: closedreopened
Summary: sshfs cannot find 'fuse' but 'macfuse' is installedmacfuse fails to build user-space library due to libtool problems

Replying to macosx12345@…:

Since I had run port in a screen session, I could look into the output of the first port install command and I noticed that there were lots of error messages like ../libtool: line 816: X--tag=CC: command not found. At the end this prevented the compilation of the library, but port kept going with staging into destroot and installed the parts of the package that go into /Liibrary/Filesystems.

I attach the outputs of the two runs of port -vu install macfuse: the first one which "silently" failed and the second one which succeeded. HTH.

Thanks, that's very helpful!

It looks like what's going on in the failed run is that automake got rerun (not sure under what circumstances that happens, or why) without rerunning glibtoolize, and libtool fails because the installed version doesn't match the one that was used to prepare the source tarball.

Forcing an autoreconf should fix this, but is a bit tricky since it's buried deep in the MacFUSE build process.

comment:15 Changed 10 years ago by drkp (Dan Ports)

Port: macfuse added; sshfs removed

comment:16 Changed 10 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed

I patched the libfuse build process in r73010 to force an autoreconf, which should fix this.

Note: See TracTickets for help on using tickets.