Opened 10 years ago

Closed 10 years ago

#25972 closed defect (fixed)

gimp @2.6.10 configure fails - "Could not find PyGTK 2.10.4 or newer."

Reported by: m214089 Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: sewebster@…, domiman@…
Port: gimp2

Description

configure fails looking for pygtk - Portfile requirements asks for py26-gtk ...

checking for PYGTK... no configure: error: * Could not find PyGTK 2.10.4 or newer.

The following ports are currently installed:

py26-gtk @2.16.0_0 (active)

Change History (8)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…
Port: gimp2 added

Please remember to fill in the Port field and cc the maintainer.

comment:2 Changed 10 years ago by sewebster@…

I get the same error. I upgraded gimp2 recently with no problems, but then removed some supposedly newly unnecessary dependencies with the switch to python 2.6. Something must have gone wrong and the lack of py25-gtk (or one of the other py25 ports) is causing a problem. You could try installing that if you are in a rush to get it working...

comment:3 Changed 10 years ago by sewebster@…

Cc: sewebster@… added

Cc Me!

comment:4 Changed 10 years ago by sewebster@…

I guess this is somewhat of a duplicate of #25962

comment:5 Changed 10 years ago by domiman@…

Cc: domiman@… added

Cc Me!

comment:6 Changed 10 years ago by domiman@…

even with doing "sudo python_select python26" prior to installing/upgrading gimp2 I get the PYGTK error :( Along with bug #26005 this was an annoying "port upgrade outdated"

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Summary: gimp 2.6.10 does not installgimp @2.6.10 configure fails - "Could not find PyGTK 2.10.4 or newer."

comment:8 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.