Opened 10 years ago

Closed 10 years ago

#26161 closed defect (duplicate)

postgresql-devel compilation error

Reported by: macports@… Owned by: chepra@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: extern.h yylenq Cc: ryandesign (Ryan Schmidt)
Port: postgresql-devel

Description (last modified by ryandesign (Ryan Schmidt))

Mac OS X Version 10.6.4
Processor 2.4 GHz Intel Core 2 Duo (Macbook Pro)

port install postgresql-devel

Compilation fails on line 43 of pgsql/src/interfaces/ecpg/ecpglib/extern.h

Changed type of yylenq from int to size_t to get it to compile and install successfully

Change History (5)

comment:1 Changed 10 years ago by blb@…

Owner: changed from macports-tickets@… to chepra@…

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)

Why do you want to use postgresql-devel? It hasn't seen an update in over a year. Try the current 8.4 version of postgresql in the postgresql84 port or the upcoming 9.0 version in the postgresql90 port. postgresql-devel should probably be marked as "replaced_by postgresql90", and later deleted.

comment:3 in reply to:  2 Changed 10 years ago by macports@…

Replying to ryandesign@…:

Why do you want to use postgresql-devel? It hasn't seen an update in over a year. Try the current 8.4 version of postgresql in the postgresql84 port or the upcoming 9.0 version in the postgresql90 port. postgresql-devel should probably be marked as "replaced_by postgresql90", and later deleted.

Thanks - now see that postgresql-devel is version 8.4RC1 and superceded by postgresql84

comment:4 in reply to:  2 Changed 10 years ago by jmroot (Joshua Root)

Replying to ryandesign@…:

postgresql-devel should probably be marked as "replaced_by postgresql90", and later deleted.

Why not updated to a trunk snapshot? Someday postgresql90 will be a stable release.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #21076.

Note: See TracTickets for help on using tickets.