Opened 7 years ago

Closed 7 years ago

#26470 closed defect (worksforme)

Mac OS X Version: 10.6 - problem install MacPorts 1.9.1

Reported by: kubincanek@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.8.2
Keywords: Cc: mf2k (Frank Schima)
Port:

Description

Hejsan I have problem upgrade to MacPorts 1.9.1 from 1.8.2 and either can not install anything. Look what displays when put command to upgrade ports:

$ sudo port -d selfupdate
Password:
--->  Updating the ports tree
DEBUG: Synchronizing ports tree(s)
Synchronizing local ports tree from rsync://rsync.macports.org/release/ports/
DEBUG: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/ports/ /opt/local/var/macports/sources/rsync.macports.org/release/ports
receiving file list ... done
PortIndex
PortIndex.quick
PortIndex_darwin_10_i386/
PortIndex_darwin_10_i386/PortIndex.quick
PortIndex_darwin_8_i386/
PortIndex_darwin_8_i386/PortIndex.quick
PortIndex_darwin_8_powerpc/
PortIndex_darwin_8_powerpc/PortIndex.quick
PortIndex_darwin_9_i386/
PortIndex_darwin_9_i386/PortIndex.quick
PortIndex_darwin_9_powerpc/
PortIndex_darwin_9_powerpc/PortIndex.quick

sent 19708 bytes  received 474197 bytes  51990.00 bytes/sec
total size is 52005346  speedup is 105.29
DEBUG: MacPorts sources location: /opt/local/var/macports/sources/rsync.macports.org/release/base
--->  Updating MacPorts base sources using rsync
receiving file list ... done
./
deleting config.log

sent 42 bytes  received 6816 bytes  1959.43 bytes/sec
total size is 2879032  speedup is 419.81
MacPorts base version 1.8.2 installed,
DEBUG: Rebuilding and reinstalling MacPorts if needed
MacPorts base version 1.9.1 downloaded.
--->  MacPorts base is outdated, installing new version 1.9.1
DEBUG: Permissions OK
Installing new MacPorts release in /opt/local as root:admin; permissions 0755; Tcl-Package in /Library/Tcl

checking build system type... i386-apple-darwin10.4.0
checking host system type... i386-apple-darwin10.4.0
checking target system type... i386-apple-darwin10.4.0
checking MacPorts version... 1.9.1
checking for sw_vers... /usr/bin/sw_vers
checking for defaults... /usr/bin/defaults
checking for xcode-select... no
checking Mac OS X version... 10.6.4
checking Xcode version... 3.2.3
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/opt/local/var/macports/sources/rsync.macports.org/release/base':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
DEBUG: Error installing new MacPorts base: shell command "cd /opt/local/var/macports/sources/rsync.macports.org/release/base && ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0755 --enable-readline && make && make install" returned error 1
    while executing
"macports::selfupdate [array get global_options]"
Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: shell command "cd /opt/local/var/macports/sources/rsync.macports.org/release/base && ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0755 --enable-readline && make && make install" returned error 1

I see at logs that gcc is missing but I have installed XCode Version 3.2.3 (1688) and donna what's goin' on cuz wanna to install recodeand can not .... please help what to do to fix it.

Change History (4)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

  • Component changed from ports to base
  • Priority changed from High to Normal

Did you change the Xcode install location to something besides the default? If so, reinstall and don't change that.

What is the output of the following?

which gcc

This is not a bug with Macports, but a support issue. Issues like this are better handled on the macports-users mailing list.

comment:2 Changed 7 years ago by mf2k (Frank Schima)

  • Cc macsforever2000@… added

Cc Me!

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Installing Xcode in a nonstandard location should be fine; you can tell MacPorts this location using the developer_dir directive in macports.conf. However, you must also install gcc in its standard location in /usr/bin; this is what the "UNIX Development" checkbox in the Xcode installer does, so you must not deselect this checkbox. If you did, reinstall Xcode, making sure that checkbox is checked.

comment:4 Changed 7 years ago by jmroot (Joshua Root)

  • Resolution set to worksforme
  • Status changed from new to closed

Closing. If you think there's really a bug here, reopen and attach the config.log.

Note: See TracTickets for help on using tickets.