Opened 10 years ago

Closed 9 years ago

#26567 closed update (fixed)

Updated yap-devel portfile

Reported by: pmoura (Paulo Moura) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc:
Port: yap-devel

Description

Updated yap-devel portfile to use YAP's git repository and defined relavant variants.

Attachments (1)

Portfile-yap-devel.diff (1.5 KB) - added by pmoura (Paulo Moura) 10 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

See comments in #26568.

comment:2 Changed 10 years ago by pmoura (Paulo Moura)

Talked with the YAP developer today and updated the portfile patch accordingly.

comment:3 Changed 10 years ago by pmoura (Paulo Moura)

Just upload a new patch file that removes tabling from the default variants as, accordingly to the YAP developer, is not stable enough to a default.

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

In the attached patch you're also incidentally requesting we change the maintainer from "mac.com:pmoura" to "logtalk.org:pmoura". Should we make the same change in your other ports as well?

comment:6 in reply to:  5 Changed 10 years ago by pmoura (Paulo Moura)

Replying to ryandesign@…:

In the attached patch you're also incidentally requesting we change the maintainer from "mac.com:pmoura" to "logtalk.org:pmoura". Should we make the same change in your other ports as well?

Yes, please. Although most of them should be already updated. Thanks.

comment:7 Changed 10 years ago by ryandesign (Ryan Schmidt)

Updated maintainer address in r71884.

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

In this patch you change "LIACC" to "CRACS" in the description; should the change be made in the yap portfile as well?

comment:9 Changed 10 years ago by pmoura (Paulo Moura)

I missed that bit :( This portfile that we're upgrading is really old. Yes, you can apply the change. Thanks.

comment:10 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Updated yap-devel in r71890, using mostly your patch with a few changes.

comment:11 Changed 10 years ago by pmoura (Paulo Moura)

Resolution: fixed
Status: closedreopened

Found a problem that it wasn't apparent until today when I tried to build an installer for the current git version. The presence of the "git.branch" line seems to be preventing retrieving the latest revision. Deleting this option solves the problem. The MacPorts Guide states: "Optional tag for fetching with git, this specifies a branch (or other commit-ish) that git should checkout.". Either I have misunderstood something or I just written the wrong value for the "git.branch" field. Your feedback is appreciated.

comment:12 Changed 10 years ago by jmroot (Joshua Root)

A given version+revision of a port should always install exactly the same thing, so you don't want to fetch the latest revision, but rather the particular one specified.

comment:13 in reply to:  12 Changed 10 years ago by pmoura (Paulo Moura)

Replying to jmr@…:

A given version+revision of a port should always install exactly the same thing, so you don't want to fetch the latest revision, but rather the particular one specified.

For a stable port, I agree. For a -devel port, I do want to fetch the latest revision. Well, at least in this case. I expect a -devel port to be used mostly by people beta-testing a new version. In this case, the latest revision is exactly want you want. By defining a -devel port, this can be done from within MacPorts.

comment:14 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Ports should be for specific versions, as Joshua said -- even -devel ports. You're free to update the -devel port at any time to a newer version, but users must be able to consistently install the same version of software.

comment:15 in reply to:  14 Changed 10 years ago by pmoura (Paulo Moura)

Resolution: fixed
Status: closedreopened

Replying to ryandesign@…:

Ports should be for specific versions, as Joshua said -- even -devel ports. You're free to update the -devel port at any time to a newer version, but users must be able to consistently install the same version of software.

When no branch is specified (and thus a default branch is used), users will always install the same *version*, but not necessarily the same *revision* (of that version). Quoting from the MacPorts Guide:

git.branch Optional tag for fetching with git, this specifies a branch (or other commit-ish) that git should checkout. Note that any branch besides HEAD should be prefixed by origin/.

Default: none

Example:

git.branch 72bf1c8 git.branch origin/next

The second example checks out the latest revision on the specified branch. At least ten other ports do exactly the same: specifying a branch name and not a specific revision. Branch names, however, often correspond to versions. Therefore, by specifying a branch, users will always get the same version but clearly not the same revision of that version (unless, of course, not commits are being made on that branch). In this particular case, the problem is fixed by simply updating the git.branch field to "origin/master". Should I submit an update portfile or is possible for you do the update manually?

comment:16 Changed 10 years ago by pmoura (Paulo Moura)

The new patch file corrects the git.branch field, turns off the universal variant, and adds missing fetch of YAP submodules.

Changed 10 years ago by pmoura (Paulo Moura)

Attachment: Portfile-yap-devel.diff added

comment:17 Changed 10 years ago by ryandesign (Ryan Schmidt)

We will not commit a patch that makes the port install from the current head of the repository trunk, or from the current head of a repository branch. A port must guarantee that always the same software is fetched, irrespective of whether the developers have committed new changes. Please set git.branch back to the specific revision of the software you'd like the port to install, and I'll be happy to commit that. If you'll let me know the ten other ports you've found that also do not restrict their version, I'll file tickets about those as well.

comment:18 Changed 10 years ago by pmoura (Paulo Moura)

Are you also going to correct the MacPorts official guide? Are you going to forbid e.g. "git.branch origin/next" from now on? Note that *-devel ports are not for regular users. For other ports doing the same as the submitted portfile just do a grep on the "sources" directory or use a text editor that allows you to search across a directory.

comment:19 Changed 9 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: reopenedclosed
Version: 1.9.1

git.branch origin/next can refer to a tag, not necessarily the head of the branch. Clarified in r89763.

Note: See TracTickets for help on using tickets.