Opened 10 years ago

Closed 10 years ago

#26603 closed update (fixed)

p5-devel-cover: update to 0.71

Reported by: r@… Owned by: narf_tm@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: p5-devel-cover

Description

Devel-Cover update to 0.71 Removed dependencies, since they are core modules in perl 5.12.1 (http://deps.cpantesters.org/?module=Devel%3A%3ACover&perl=5.12.1&os=any+OS)

Attachments (2)

Portfile (532 bytes) - added by r@… 10 years ago.
Portfile.diff (1.0 KB) - added by r@… 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by r@…

Attachment: Portfile added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: narf_tm@… removed
Owner: changed from macports-tickets@… to narf_tm@…
Port: p5-devel-cover added
Summary: p5-devel-coverp5-devel-cover: update to 0.71

MacPorts still uses perl5.8 by default; should the dependencies be kept then?

When submitting updates, please submit unified diffs, not complete portfiles, so we can see what changes you're proposing.

comment:2 Changed 10 years ago by r@…

Yes they should be kept. Is there any policy in upgrading perl, or how to set dependency on exact perl version? Still, dependencies is on core modules, diff is in attachment.

The thing is I want port Publican to osx, preferably push it into macports, but Publican use som perl modules ( eg. Makefile::DOM ), that are dependent on core modules in perl >= 5.10. Forcing installation of core modules from ports is generaly a bad idea, so the only viable option is to use more current perl. But this is offtopic in this ticket, I will open new ticket on this issue.

Changed 10 years ago by r@…

Attachment: Portfile.diff added

comment:3 Changed 10 years ago by narf_tm@…

Resolution: fixed
Status: newclosed

This port has been updated to 0.73.

Note: See TracTickets for help on using tickets.