Opened 10 years ago

Closed 10 years ago

#26649 closed defect (invalid)

Can't extract aquaterm

Reported by: chavezo@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: aquaterm

Description

Powermac G5
Mac OS X 10.5.8
xCode 3.1.3
MacPorts 1.9.1

To install maxima I typed the command:

sudo port install maxima @5.22.1

This is what I got:

--->  Computing dependencies for maxima
--->  Dependencies to be installed: gnuplot aquaterm expat fontconfig freetype zlib libiconv gperf gd2 autoconf help2man gettext ncurses ncursesw p5-locale-gettext perl5 perl5.8 m4 automake jpeg libpng libtool xpm pkgconfig xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 bzip2 db46 gdbm openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice pdflib recode sbcl tk Xft2 xrender xorg-renderproto tcl xorg-libXScrnSaver xorg-scrnsaverproto
--->  Extracting aquaterm
Error: Target org.macports.extract returned: shell command failed
Log for aquaterm is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_aquaterm/main.log
Error: The following dependencies failed to build: gnuplot aquaterm expat fontconfig freetype zlib libiconv gperf gd2 autoconf help2man gettext ncurses ncursesw p5-locale-gettext perl5 perl5.8 m4 automake jpeg libpng libtool xpm pkgconfig xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 bzip2 db46 gdbm openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice pdflib recode sbcl tk Xft2 xrender xorg-renderproto tcl xorg-libXScrnSaver xorg-scrnsaverproto
Error: Status 1 encountered during processing.

That is a lot of dependencies!

Attachments (1)

main.log (7.2 KB) - added by chavezo@… 10 years ago.
Log file for aquaterm

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by chavezo@…

Attachment: main.log added

Log file for aquaterm

comment:1 Changed 10 years ago by chavezo@…

Apparently the problem is with aquaterm. See attached log file. I upgraded xCode to 3.1.4, and it doesn't seem to make any difference.

comment:2 Changed 10 years ago by chavezo@…

Cc: chavezo@… added

Cc Me!

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: chavezo@… removed
Owner: changed from macports-tickets@… to mcalhoun@…
Port: aquaterm added
Summary: Can't install maximaCan't extract aquaterm

Please remember to fill in the Port field and cc the maintainer.

comment:4 Changed 10 years ago by mf2k (Frank Schima)

The relevant error is:

:info:extract sh: /usr/bin/gnutar: No such file or directory

I'm not sure why you don't have that. Any idea? This is really an error in your setup because that application should exist there. I assume you have no other ports installed?

FYI the proper way to install maxima is:

sudo port install maxima

You cannot choose a version, only the latest one is attempted.

comment:5 Changed 10 years ago by chavezo@…

Thanks for the prompt response.

I'm sorry, I don't know what gnutar is or why I haven't installed (is it a GNU application for uncompressing tar files?). I don't have other ports installed. How would I get gnutar? From Apple's development tools? From a standard installation of Mac OS 10.5?

Any suggestions will be much appreciated.

comment:6 Changed 10 years ago by mf2k (Frank Schima)

It either comes with the OS or Xcode. I'm not easily able to test which right now. You said you "upgraded" to Xcode 3.1.4. Does that mean you installed it from scratch? The easy thing to try is to install Xcode 3.1.4 fresh.

comment:7 in reply to:  6 Changed 10 years ago by chavezo@…

Replying to macsforever2000@…:

It either comes with the OS or Xcode. I'm not easily able to test which right now. You said you "upgraded" to Xcode 3.1.4. Does that mean you installed it from scratch? The easy thing to try is to install Xcode 3.1.4 fresh.

I downloaded xCode 3.1.4 and installed it. By default, xCode upgrades the previous version, or so I understand. I just tried to install gnutar using MacPorts, to no avail:

/Users/oscar% sudo port install gnutar
Password:
--->  Computing dependencies for gnutar
--->  Dependencies to be installed: gettext expat libiconv gperf ncurses ncursesw
--->  Fetching expat
--->  Attempting to fetch expat-2.0.1.tar.gz from http://superb-east.dl.sourceforge.net/expat
--->  Attempting to fetch expat-2.0.1.tar.gz from http://superb-west.dl.sourceforge.net/expat
--->  Attempting to fetch expat-2.0.1.tar.gz from http://downloads.sourceforge.net/expat
--->  Verifying checksum(s) for expat
--->  Extracting expat
Error: Target org.macports.extract returned: shell command failed
Log for expat is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_expat/main.log
Error: The following dependencies failed to build: gettext expat libiconv gperf ncurses ncursesw
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log file for expat is at http://dl.dropbox.com/u/3709792/main.log

On the other hand, I just installed MacPorts in a MacBook Pro running 10.6.4 and xCode 3.2.3 and it is happily installing maxima, as I type this. It is finding, extracting, and installing all the dependencies, including aquaterm.

comment:8 Changed 10 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

So it's not from Xcode. Clearly your OS install got corrupted. In any event, this is not a problem with Macports because gnutar is supposed to be there. I suggest reinstalling the OS on that machine.

Note: See TracTickets for help on using tickets.