Opened 10 years ago

Closed 10 years ago

#26698 closed defect (worksforme)

cmake fails when building shared-desktop-ontologies (libssl.0.9.8.dylib lacking)

Reported by: f.dumas@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: nerdling (Jeremy Lavergne), sharky@…
Port: cmake shared-desktop-ontologies

Description

Installing Kdenlive package, mac port stumbled several times installing required dependencies. I worked around to get glib2 installed, but failed to solve the matter with shared-desktop-ontologies.

shared-desktop-ontologies fails to install, claiming that libssl.0.9.8.dylib is lacking. That is right, as libssl.1.0.0.dylib has been installed already.

The following log is attached to the report: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_shared-desktop-ontologies/main.log

Environment: OS.X 10.5.8 XCode 3.1.4 MacPort 1.9.1

Attachments (1)

main.log (4.5 KB) - added by f.dumas@… 10 years ago.
kde-shared-desktop-ontologies installation log

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by f.dumas@…

Attachment: main.log added

kde-shared-desktop-ontologies installation log

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: snc@… sharky@… added
Owner: changed from macports-tickets@… to css@…
Port: cmake shared-desktop-ontologies added; kde-shared-desktop-ontologies removed
Summary: kde-shared-desktop-ontologies fails to install (libssl.0.9.8.dylib lacking)cmake fails when building shared-desktop-ontologies (libssl.0.9.8.dylib lacking)

Please be sure to enter the port name correctly, and remember to cc its maintainer.

Cmake has been updated a few times since openssl was updated to 1.0.0a, so everything should have ended up linked correctly if you just did a normal upgrade. If you upgraded things in the wrong order by using -n or -R or manually activating the old openssl version, then you'll just have to reinstall cmake to get it linked against the current openssl.

comment:2 Changed 10 years ago by cssdev

Status: newassigned

Yes, it sounds like a dependency was updated, and the binary does not link with the current version. Try reinstalling the cmake port.

sudo port uninstall cmake
sudo port clean --archive cmake
sudo port install cmake

comment:3 Changed 10 years ago by f.dumas@…

Thanks to both of you.

sudo port upgrade --force cmake

solved the case (I had to cure qt4-mac/makekdewidgets the same way, see ticket #26722). By the way, I cannot remember that I ever used -n or -R option or manually activated the version 0.9.8 of openssl.

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: assignedclosed

OK, glad you got it working.

Note: See TracTickets for help on using tickets.