Opened 10 years ago

Closed 10 years ago

#26708 closed defect (duplicate)

apt building error

Reported by: damec56@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: apt

Description (last modified by jmroot (Joshua Root))

On snow leopard, when trying

sudo port -v install apt, I obtain this error

--->  Building apt
Compiling contrib/md5.cc to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/md5.opic
Compiling contrib/hashes.cc to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/hashes.opic
Compiling contrib/sha1.cc to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/sha1.opic
Compiling sourcelist.cc to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/sourcelist.opic
contrib/hashes.cc: In member function 'bool Hashes::AddFD(int, long unsigned int)':
contrib/hashes.cc:33: error: expected primary-expression before '?' token
contrib/hashes.cc:33: error: expected `:' before ')' token
contrib/hashes.cc:33: error: expected primary-expression before ')' token
contrib/hashes.cc:34: error: expected primary-expression before '?' token
contrib/hashes.cc:34: error: expected `:' before ')' token
contrib/hashes.cc:34: error: expected primary-expression before ')' token
gnumake[2]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/hashes.opic] Error 1
gnumake[2]: *** Waiting for unfinished jobs....
contrib/md5.cc: In member function 'bool MD5Summation::AddFD(int, long unsigned int)':
contrib/md5.cc:302: error: expected primary-expression before '?' token
contrib/md5.cc:302: error: expected `:' before ')' token
contrib/md5.cc:302: error: expected primary-expression before ')' token
contrib/md5.cc:303: error: expected primary-expression before '?' token
contrib/md5.cc:303: error: expected `:' before ')' token
contrib/md5.cc:303: error: expected primary-expression before ')' token
gnumake[2]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/md5.opic] Error 1
contrib/sha1.cc: In member function 'bool SHA1Summation::AddFD(int, long unsigned int)':
contrib/sha1.cc:348: error: expected primary-expression before '?' token
contrib/sha1.cc:348: error: expected `:' before ')' token
contrib/sha1.cc:348: error: expected primary-expression before ')' token
contrib/sha1.cc:349: error: expected primary-expression before '?' token
contrib/sha1.cc:349: error: expected `:' before ')' token
contrib/sha1.cc:349: error: expected primary-expression before ')' token
gnumake[2]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build/obj/apt-pkg/sha1.opic] Error 1
gnumake[1]: *** [all] Error 2
gnumake: *** [all] Error 2
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/work/apt-0.5.27/build" && /usr/bin/gnumake all " returned error 2
Error: Target org.macports.build returned: shell command failed
Warning: the following items did not execute (for apt): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Log for apt is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_apt/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (2)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to landonf@…

Please remember to preview and use WikiFormatting, and to cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Probably just comes down to the fact that 0.5.27 is really old, so I'm marking this as a dupe of #13425.

Note: See TracTickets for help on using tickets.