Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#26723 closed defect (fixed)

MacVim @7.3.snapshot54 build fails

Reported by: larryv (Lawrence Velázquez) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: todmorrison (Tod Morrison), volker.menrad@…
Port: MacVim

Description

Upgrading from MacVim @7.3.snapshot53+cscope+huge to @7.3.snapshot54+cscope+huge fails during the build phase with the following output. I receive the same failure after uninstalling, cleaning, and reinstalling, and also after attempting to install vanilla MacVim-7.3snapshot54.

--->  Computing dependencies for MacVim
--->  Fetching MacVim
--->  Attempting to fetch MacVim-7.3.snapshot54.zip from
            http://github.com/b4winckler/macvim/zipball/snapshot-54
--->  Verifying checksum(s) for MacVim
--->  Extracting MacVim
--->  Configuring MacVim
--->  Building MacVim
Error: Target org.macports.build returned: shell command failed
Log for MacVim is at: /opt/local/var/macports/logs/
            _opt_local_var_macports_sources_rsync.macports.org_release_ports_editors_MacVim/
            main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log seems to go to hell at this point (edited for brevity, see attached log file for actual output):

:info:build ** BUILD FAILED **
:info:build 
:info:build 
:info:build The following build commands failed:
:info:build PSMTabBarControlFramework:
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build 	CompileC ../build/PSMTabBarControl.build/<blahblahblah>
:info:build MacVim:
:info:build 	Ld /opt/local/var/macports/build/<blah>
:info:build (11 failures)

followed by the usual cascading make and port errors.

I'm using MacPorts 1.9.1 on Mac OS X Snow Leopard 10.6.4 (10F569). The specified log file is attached.

Attachments (2)

main.log (184.6 KB) - added by larryv (Lawrence Velázquez) 11 years ago.
MacVim log
Portfile-MacVim.diff (464 bytes) - added by volker.menrad@… 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by larryv (Lawrence Velázquez)

Attachment: main.log added

MacVim log

comment:1 Changed 11 years ago by larryv (Lawrence Velázquez)

Apologies, I neglected to cc the maintainer, raimue@….

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to raimue@…

comment:3 Changed 11 years ago by todmorrison (Tod Morrison)

Cc: todmorrison@… added

Cc Me!

comment:4 Changed 11 years ago by raimue (Rainer Müller)

Status: newassigned

I am unable to reproduce this issue, even with +cscope+huge. I can't see any real error message in the log file. I guess xcodebuild does not print them and I don't know if it leaves a build log file somewhere in work/MacVim/src/MacVim/build/?

I am using Xcode 3.2.3, I will try if this might be a problem with 3.2.4 only:

$ xcodebuild -version
Xcode 3.2.3
Component versions: DevToolsCore-1691.0; DevToolsSupport-1591.0
BuildVersion: 10M2262

comment:5 in reply to:  4 Changed 11 years ago by larryv (Lawrence Velázquez)

Replying to raimue@…:

This is my xcodebuild output, if it's of any use.

% xcodebuild -version
Xcode 3.2.4
Component versions: DevToolsCore-1705.0; DevToolsSupport-1591.0
BuildVersion: 10M2309

Changed 11 years ago by volker.menrad@…

Attachment: Portfile-MacVim.diff added

comment:6 Changed 11 years ago by volker.menrad@…

Got the same error as larry (with the default variant). In particular

error: one or more PCH files were found, but they were invalid
error: use -Winvalid-pch for more information

It seems that the PCH file was left by some older compilation in the global cache directory. So I changed the location of the precompiled headers using the above patch and it now compiles and runs for me.

comment:7 Changed 11 years ago by volker.menrad@…

Cc: volker.menrad@… added

Cc Me!

comment:8 Changed 11 years ago by raimue (Rainer Müller)

Interesting. Where does Xcode store these files normally? Could it be, that it does compare timestamps of headers and pre-compiled files? So if you build the older version after the new version was released (timestamp in tarball at release time), it considers them to be newer.

Sounds like it might be a good idea to add this to the xcode port group.

comment:9 Changed 11 years ago by raimue (Rainer Müller)

I found additional information in the Mac OS X Reference Library. Sounds like it might be a good idea to change CACHE_ROOT to a temporary location.

comment:10 Changed 11 years ago by foolswisdom@…

Deleting the files in /var/folders/ allowed me to install MacVim @7.3.snapshot55_0+cscope.

comment:11 Changed 11 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: assignedclosed

Fixed in r72421.

comment:12 in reply to:  11 Changed 11 years ago by larryv (Lawrence Velázquez)

Replying to raimue@…:

Fixed in r72421.

Just confirming that the build now works for me. Thanks!

Note: See TracTickets for help on using tickets.