Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26789 closed defect (invalid)

error trying to upgrade to SnowLeopard

Reported by: dnaumann Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port:

Description (last modified by mf2k (Frank Schima))

I upgraded to SnowLeopard (and Xcode 3.2) and most of my ports kept working, but port itself did not. I understand I need to reinstall ports, according to this page: http://trac.macports.org/wiki/Migration but I can't, for two reasons:

  • I don't have a macports.conf to update (maybe that's fine)
  • I can't run port to get a list of installed ports. Here's the error message:
    ~>sudo port selfupdate
    Password:
    dlopen(/Library/Tcl/macports1.0/MacPorts.dylib, 10): no suitable image found.  Did find:
    	/Library/Tcl/macports1.0/MacPorts.dylib: mach-o, but wrong architecture
        while executing
    "load /Library/Tcl/macports1.0/MacPorts.dylib"
        ("package ifneeded macports 1.0" script)
        invoked from within
    "package require macports"
        (file "/opt/local/bin/port" line 39)
    

Change History (2)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Resolution: invalid
Status: newclosed
Type: requestdefect

I'm closing this ticket since it's not a problem with Macports. Technical support is handled with the Macports-users mailing list.

You can install Macports 1.9.1 for Snow Leopard and the port command will work again. FYI, you should download and install Xcode 3.2.4 rather than use the version on the Snow Leopard disc.

comment:2 Changed 10 years ago by dnaumann

You're right, I wasn't thinking. I appreciate the helpful reply.

Note: See TracTickets for help on using tickets.