Opened 10 years ago

Closed 10 years ago

#26963 closed defect (duplicate)

building db46 on 10.6.4 fails: cannot find jni.h

Reported by: kelvin.bitnick@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: build failure db46 jni.h Cc: blair (Blair Zajac)
Port: db46

Description (last modified by jmroot (Joshua Root))

On a fresh 10.6.4, installing macports 1.9.1 went fine up to db46. from there, I got the following:

--->  Building db46
Error: Target org.macports.build returned: shell command failed
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: The following dependencies failed to build: xrender xorg-libX11 xorg-libxcb python26 db46 gdbm openssl sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

in the logfile:

:info:build ../dist/../libdb_java/db_java_wrap.c:123:17: error: jni.h: No such file or directory:info:build ../dist/../libdb_java/db_java_wrap.c:147: error: expected ')' before '*' token
:info:build ../dist/../libdb_java/db_java_wrap.c:196: error: expected ')' before '*' token:info:build ../dist/../libdb_java/db_java_wrap.c:200: error: expected '=', ',', ';', 'asm' or '__attribute__
' before '*' token

and in /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/JavaVM.framework/Versions/Current/Headers/jni.h :

/*
 * @(#)jni.h    1.62 06/02/02
 *
 * Copyright 2006 Sun Microsystems, Inc.  All rights reserved.
 * SUN PROPRIETARY/CONFIDENTIAL.  Use is subject to license terms.
 */

/*
 * We used part of Netscape's Java Runtime Interface (JRI) as the starting
 * point of our design and implementation.
 */

/******************************************************************************
 * Java Runtime Interface
 * Copyright (c) 1996 Netscape Communications Corporation. All rights reserved.
 *****************************************************************************/

#ifndef _JAVASOFT_JNI_H_
#define _JAVASOFT_JNI_H_

#include <stdio.h>
#include <stdarg.h>

/* jni_md.h contains the machine-dependent typedefs for jbyte, jint
   and jlong */
...

I've just installed macports 1.9.1 from scratch on 10.5.8 and no such error was triggered

Change History (2)

comment:1 Changed 10 years ago by develop@…

Hello, seems like a problem with the new java update from apple. Duplicate of http://trac.macports.org/ticket/26934

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: blair@… added
Description: modified (diff)
Priority: HighNormal
Resolution: duplicate
Status: newclosed

Please remember to preview and use WikiFormatting, and to cc the maintainer. As per the ticket guidelines, the High priority is reserved for the use of MacPorts team members.

This is a duplicate of #26939; please search before filing new tickets.

Note: See TracTickets for help on using tickets.