Opened 10 years ago

Closed 10 years ago

#26966 closed defect (invalid)

Readline install error: 'MB_CUR_MAX' undeclared

Reported by: Thomas.Jones@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: readline

Description

Hello,

I have run into a rather strange problem whereby the readline port will not install on my MacPro running 10.6.4 with all the latest updates. I need readline to install to complete the installation of py26-numpy, ImageMagick, etc. What is strange is that it worked on my machine a couple of weeks ago, but I needed to make a new /opt/local to clear up some netcdf vs hdf issues I was having. The only other change in my configuration was the recent Java update that broke the db46 port. I installed the developer tools to fix that, but have now run into the readline issue. Basically, it crashes with this error: error: 'MB_CUR_MAX' undeclared. I can't find a previous mention of this specific error macports.org, leading me to ask now. Is it possible something with the java upgrade broke this too? (I can't really see how though). My log file is attached.

Thanks, Thomas Jones

Attachments (1)

main.log (27.4 KB) - added by Thomas.Jones@… 10 years ago.
Log file for readline

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Thomas.Jones@…

Attachment: main.log added

Log file for readline

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Keywords: MB_CUR_MAX removed
Owner: changed from macports-tickets@… to mcalhoun@…
Summary: Readline install errorReadline install error: 'MB_CUR_MAX' undeclared

Please remember to cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

I can't reproduce this, also on a fully updated 10.6 system. MB_CUR_MAX is defined in stdlib.h, which is included by at least search.c.

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Do you maybe have an old readline in /usr/local?

comment:4 in reply to:  description ; Changed 10 years ago by Thomas.Jones@…

Thanks for the comments. I will check on these suggestions when I'm at the office tomorrow and post an update.

comment:5 in reply to:  4 Changed 10 years ago by Thomas.Jones@…

Problem solved. My stdlib.h file was in the correct location in "/usr/local/". To compile readline, I had to run the configuration manually and the stdlih.h was magically found. Everything associated with readline compiled after running make install, and after manually activating it in port, the rest of the py26-numpy install proceeded normally. I don't know exactly why this worked, but at least it did. Thanks for the suggestions, they helped me get to the bottom of this.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.