Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26967 closed defect (duplicate)

db46 fails to build, java problem

Reported by: anders.thorseth@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: blair (Blair Zajac), james@…
Port: db46

Description

After following the "migration" instruction to 10.6.4 I get the following message when trying to build db46:

--->  Computing dependencies for db46
--->  Building db46
Error: Target org.macports.build returned: shell command failed
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: Status 1 encountered during processing.

The end of the log can be seen below

:info:build ../dist/../libdb_java/db_java_wrap.c:10071: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
:info:build make: *** [db_java_wrap.lo] Error 1
:info:build make: *** Waiting for unfinished jobs....
:info:build  /usr/bin/gcc-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../db_codegen/db_codegen.c  -fno-common -DPIC -o .libs/db_codegen.o
:info:build  /usr/bin/gcc-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../db_codegen/db_codegen.c -o db_codegen.o >/dev/null 2>&1
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/work/db-4.6.21/build_unix" && /usr/bin/make -j2 all " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for db46): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log

Attachments (2)

main.log (458.5 KB) - added by anders.thorseth@… 10 years ago.
logfile
main.2.log (458.6 KB) - added by james@… 10 years ago.
Build log for db46

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by anders.thorseth@…

Attachment: main.log added

logfile

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: openmaintainer@… removed
Resolution: duplicate
Status: newclosed

Duplicate of #26939; please search before filing new tickets.

comment:2 Changed 10 years ago by anders.thorseth@…

Excuse me, but I do not undersand how this is a duplicate. The error message is different and the issue is not solved by installing Java for Mac OS X 10.6 Update 3 Developer Package.

comment:3 Changed 10 years ago by james@…

Resolution: duplicate
Status: closedreopened

I have same problem and https://svn.macports.org/ticket/26939 solution did not fix it either.

Changed 10 years ago by james@…

Attachment: main.2.log added

Build log for db46

comment:4 Changed 10 years ago by james@…

Cc: james@… added

Cc Me!

comment:5 Changed 10 years ago by blair (Blair Zajac)

@james, did you retry reinstalling xcode? It would be good to see if that helps.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

The error message is exactly the same as #26939: "jni.h: No such file or directory"

comment:7 Changed 10 years ago by anders.thorseth@…

Remember to change the order of the versions in Java Preferences.app... (system) should be on top. That did it for me anyway.

comment:8 Changed 10 years ago by james@…

Thanks! That did it!

Note: See TracTickets for help on using tickets.